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SCXI  Quick Start Guide
Signal Conditioning eXtensions for Instrumentation

This document assumes you have already installed, configured, and tested 
a data acquisition (DAQ) device. If you have not done so, follow the 
instructions in the DAQ Quick Start Guide for NI-DAQ 7.0 included with 
the DAQ device before continuing. This document does not cover 
PXI chassis, PXI combo chassis, the SCXI-1000DC chassis, the SCXI 
switch modules, multichassis systems, or parallel-mode operation of any 
module. Refer to the module, chassis, or cable adapter documentation for 
information on these topics. If you are installing an SCXI switch, refer to 
the NI Switches Getting Started Guide.
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Conventions
The following conventions are used in this guide.

» The » symbol leads you through nested menu items and dialog box options 
to a final action. The sequence File»Page Setup»Options directs you to 
pull down the File menu, select the Page Setup item, and select Options 
from the last dialog box.

This icon denotes a note, which alerts you to important information.

This icon denotes a caution, which advises you of precautions to take to 
avoid injury, data loss, or a system crash.

bold Bold text denotes items that you must select or click in the software, such 
as menu items and dialog box options.

italic Italic text denotes variables, emphasis, a cross reference, or an introduction 
to a key concept. This font also denotes text that is a placeholder for a word 
or value that you must supply.

monospace Text in this font denotes text or characters that you should enter from the 
keyboard, sections of code, programming examples, and syntax examples. 
This font is also used for the proper names of disk drives, paths, directories, 
programs, subprograms, subroutines, device names, functions, operations, 
properties, methods, variables, filenames and extensions, and code 
excerpts.
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Measurement System Overview
Figure 1 depicts the measurement system overview, showing the path of 
real-world physical phenomena to your measurement application. Signal 
conditioning components use sensors and transducers to measure signals 
analyzed and presented through application software.

Figure 1.  Measurement System Overview
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Step 1. Unpack the Module and Accessories
Your module is shipped in an antistatic package to prevent electrostatic 
damage (ESD) to the module. ESD can damage several components on the 
module.

Caution Never touch the exposed pins of connectors.

To avoid such damage when you handle the module, take the following 
precautions:

• Ground yourself using a grounding strap or by holding a grounded 
object.

• Touch the antistatic package to a metal part of the chassis before 
removing the module from the package.

Remove the module from the package and inspect the module for loose 
components or any sign of damage. Notify NI if the module appears 
damaged in any way. Do not install a damaged module in the chassis.

Store the module in the antistatic package when the module is not in use.

Refer to the device documentation for safety and compliance information.
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Step 2. Verify the Components
Make sure you have the basic components.

1 Terminal Block or TBX Accessories (Optional)
2 SCXI Modules
3 SCXI-1000 or SCXI-1001 Chassis
4 Chassis Power Cord

5 Cable Assembly (Shielded Cable and 
Cable Adapter)

6 DAQ Device
7 Personal Computer

1 2 3 4

C 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 C

V 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 V

SCXI

1140 

SCXI

1140 

®

MAINFRAME 

SCXI

5 6 7



SCXI Quick Start Guide 6 ni.com

Step 3. Set up the Chassis

Caution Follow proper ESD precautions to ensure you are grounded before installing the 
hardware.

1. Power off and unplug the chassis.

2. Set the chassis address switches to off. In the following figure, 
all switches are shown in the off position.

Note Older chassis use jumpers inside the front panel, instead of chassis address switches. 
Older chassis also differ in fuses and AC power selection. Refer to the chassis 
documentation for more information.

3. Confirm the correct power settings (100, 120, 220, or 240 VAC).

4. Connect the power cord.

1 Chassis Power Switch
2 Chassis Address Switches

3 Chassis Power Settings
4 Power Cord Connector
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Step 4. Install Modules

Caution Make sure the chassis is powered off. 

1. Insert all of the modules into the chassis. 

2. Tighten the module thumbscrews.

1 Thumbscrews 2 Module
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Step 5. Attach Terminal Blocks
Attach the terminal blocks to the front of the modules. Refer to ni.com/
products to determine valid terminal block and module combinations. 
Refer to the TBX installation guide for the terminal block if you are using 
a TBX adapter.

Step 6. Attach Sensors
Wire sensors to the terminal block or accessory terminals.

• For signal connection information, refer to the module or accessory 
documentation.

• If any module in the SCXI system has switch or jumper settings, refer 
to the Getting Started with SCXI document for more information about 
configuring the hardware.

• For more information about sensors, refer to the following documents:

– If you are using sensors, refer to ni.com/sensors.

– If you are using LabVIEW, refer to the LabVIEW Measurements 
Manual packaged with LabVIEW or available from ni.com/
manuals.

– If you are using other application software, refer to the NI-DAQmx 
Help for information on common measurements. Access the help 
from Start»Programs»National Instruments»NI-DAQ»
NI-DAQmx Help.

1 Modules with Installed Terminal Blocks
2 Attaching a Terminal Block to the 

SCXI Module

3 SCXI Module Front Panels
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Step 7. Connect Modules to the DAQ Device
1. Attach the cable adapter, if necessary.

• If you have several modules in the system, determine which of the 
modules occurs first in the following list. Attach the cable adapter 
to the rear connector of this SCXI module. 

– SCXI-1520, SCXI-1530, SCXI-1531, SCXI-1540, 
SCXI-1581, SCXI-1140

– SCXI-1102, SCXI-1102/B/C, SCXI-1104/C, SCXI-1112, 
SCXI-1125, SCXI-1126, SCXI-1141, SCXI-1142, 
SCXI-1143

– SCXI-1100, SCXI-1120/D, SCXI-1121, SCXI-1122

– SCXI-1124, SCXI-116x

• If you have only one module, attach the cable adapter to the 
module.

Use the screws provided to secure the adapter to the chassis.

Caution Do not force the adapter if there is resistance. Forcing the adapter can bend pins. 

2. Connect one end of the cable to the adapter or module and the other 
end to the DAQ device. Notice which SCXI module is connected to the 
DAQ device; you will use this information in a later step.

Step 8. Power on the SCXI Chassis
The chassis power switch is shown in Step 3. Set up the Chassis.

Step 9. Launch Measurement & Automation Explorer (MAX)
Double-click the Measurement & Automation icon on the desktop to 
launch MAX.

Note Refer to the Hardware Installation Wizard at ni.com/support/install 
for SCXI configuration instructions with RT Series products. Select Hardware 
Configuration and click Real-Time Configuration Wizard.
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Step 10. Add the SCXI Chassis
1. Right-click Devices and Interfaces and select Create New.

2. Select the SCXI chassis from the Create New window. 

If you are using more than one NI-DAQ API to control an SCXI 
chassis in your application, add the chassis in each NI-DAQ API 
you are using.

• If you are using Traditional NI-DAQ, select the chassis under 
Traditional NI-DAQ Device.

• If you are using NI-DAQmx, select the chassis under NI-DAQmx 
Device»NI-DAQmx SCXI Chassis.

When a device is supported by both Traditional NI-DAQ and 
NI-DAQmx and both are installed, the same device is listed with a 
different name under the Traditional NI-DAQ and NI-DAQmx folders 
in Devices and Interfaces.

Note For more information about the Traditional NI-DAQ and NI-DAQmx Application 
Programming Interfaces (APIs), refer to the DAQ Quick Start Guide for NI-DAQ 7.0.

3. Click Finish when you are done. A configuration window appears. 
Refer to Step 11. Configure the Chassis for more information.

If your device does not automatically appear, press <F5> to refresh the 
view in MAX. If the device is still not recognized, refer to ni.com/
support/install for troubleshooting information.

If you are using Traditional NI-DAQ, there is an alternative way to add an 
SCXI chassis. Right-click Devices & Interfaces»Traditional NI-DAQ 
Devices and select Add SCXI Chassis.
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If you are using NI-DAQmx, there is an alternative way to add an SCXI 
chassis. Right-click Devices & Interfaces»NI-DAQmx Devices and select 
Create New NI-DAQmx Device. Select NI-DAQmx SCXI Chassis and 
choose the chassis.

Step 11. Configure the Chassis
The configuration process differs depending on the NI-DAQ API you are 
using to control the chassis—Traditional NI-DAQ or NI-DAQmx.

Traditional NI-DAQ
If you are using Traditional NI-DAQ, complete the following steps, 
as shown in the figures, to configure the SCXI chassis.

1. Select an ID for the SCXI chassis. The ID can be any integer between 
1 and 3,200. Use this ID to identify the chassis in your application.

2. Enter the chassis address setting. The chassis address can be any value 
between 0 and 31. Make sure the setting matches the chassis address 
switches on the SCXI chassis. Refer to Step 3. Set up the Chassis for 
help locating the chassis address switches. Click Next. 

3. Select whether or not to auto-detect SCXI modules. Click Next.

21 3
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4. Select the DAQ device, which acts as the communication path between 
the chassis and the computer. Click Next.

5. Select the SCXI module that is cabled to the communication device. 
If the chassis has only one module, NI-DAQ selects the module by 
default.

6. Click Finish to accept the settings.

4 5

6
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NI-DAQmx
If you are using NI-DAQmx, complete the following steps, as shown in the 
figures, to configure the chassis.

1. Select the DAQ device cabled to the communicating SCXI module 
from Chassis Communicator. If MAX detects only one DAQ device, 
the device is chosen by default, and this option is disabled.

2. Select the module slot connected to the chassis communicator from 
Communicating SCXI Module Slot.

3. Enter the chassis address setting in Chassis Address. Make sure the 
setting matches the address setting on the SCXI chassis.

4. Select whether or not to auto-detect SCXI modules. If you do not 
auto-detect modules, MAX disables Communicating SCXI Module 
Slot.

Caution Auto-detecting modules may place the modules in an unknown or undesirable 
state. Disconnect any connected devices for which auto-detection could present problems.

5. Click Save.

1

2

3

4

5
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6. The SCXI Chassis Configuration window opens. The Modules tab is 
selected by default. If you did not auto-detect modules, select an SCXI 
module from the Modules listbox. Be sure to locate the module in the 
correct slot.

7. MAX provides a default name for the Device Name field. To change 
the name, click in the field and enter a unique alphanumeric ID for the 
SCXI module.

8. If you are using a connected accessory, select it from Accessory.

9. Click Details for more configuration options. Refer to Step 12. 
Configure the SCXI Modules for more information.

10. If you need to change any chassis settings, click the Chassis tab. 
Most users will not need to change chassis settings.

11. Click OK to accept and save the settings for this chassis.

Note You cannot save the chassis configuration until you finish entering module 
information. A message at the top of the SCXI Chassis Configuration window alerts you 
of the status of the configuration. You cannot save if an error appears in the message box. 
If a warning appears in the message box, you can save the configuration, although NI 
recommends fixing the source of the warning before saving.

610 7 8 9

11
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Step 12. Configure the SCXI Modules
The configuration process differs depending on the NI-DAQ API you are 
using to program the modules—Traditional NI-DAQ or NI-DAQmx.

Traditional NI-DAQ
If you are using Traditional NI-DAQ, complete the following steps to 
configure the SCXI modules.

1. Select the chassis from Devices and Interfaces»Traditional 
NI-DAQ Devices.

2. Right-click a module slot and choose Properties.
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3. The General tab is selected by default. Choose which DAQ device 
connects to the module from Connected to. Select the checkbox if the 
DAQ device controls the chassis.

4. Some modules require an operating mode—multiplexed or parallel. 
Select a mode from Operating Mode.

5. Some modules feature software-selectable filter and/or gain settings 
for each channel. Available settings vary between modules. If 
applicable, click the Channel tab. Select settings from the displayed 
fields.



© National Instruments Corporation 17 SCXI Quick Start Guide

6. Click the Accessory tab. Select a compatible device from the 
Accessory listbox.

7. Click OK to accept the settings.
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NI-DAQmx
If you are using NI-DAQmx, complete the following steps to configure the 
modules. You can skip this step if you are using a single MIO device with 
your SCXI system in multiplexed mode.

1. Select the chassis from Devices and Interfaces»NI-DAQmx Devices.

2. Right-click the module and choose Properties.

Note You also can access module properties by selecting the Modules tab of the SCXI 
Chassis Configuration window and clicking Details.
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3. Some SCXI modules have jumper-selectable settings. If you are 
configuring such a module, click the Jumpers tab and enter the 
hardware-selected settings.

4. Click the Accessory tab.

5. To change the accessory selected during chassis configuration, select a 
module accessory from the Accessory drop-down listbox.

6. Click Configure to edit accessory settings. Not all accessories have 
settings. Refer to the accessory documentation for more information.

7. If you are using an AI module, click the Cabling tab.
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Note You will not have to adjust the information in the cabling tab if you are using 
standard multiplexed mode operation. If you are using parallel mode operation, 
multichassis configuration, or another special configuration, adjust the options on the 
Cabling tab.

8. Select the DAQ device connected to the SCXI module from the Which 
device connects to this module? drop-down listbox. In most cases, 
the device selected here and the module digitizer are the same.

9. Select a DAQ device from the Module Digitizer drop-down listbox. 
The device can be different from the device selected from the Which 
device connects to this module? listbox.

10. If operating in parallel mode, click Parallel Mode.

11. If the module is installed in a daisy-chained chassis, select an index 
number from the Multichassis Daisy-Chain Index drop-down 
listbox. The listbox appears only if two or more chassis have been 
added and saved.

12. Click OK.

For information about software-configurable properties of the module, 
refer to the Measurement & Automation Explorer Help for Traditional 
NI-DAQ or the Measurement & Automation Explorer Help for NI-DAQmx. 
To access this help in MAX, select Help»Help Topics»Traditional 
NI-DAQ or Help»Help Topics»NI-DAQmx.



© National Instruments Corporation 21 SCXI Quick Start Guide

Step 13. Test the Chassis
Verify that MAX recognizes the chassis.

1. Right-click the chassis name in the NI-DAQ API you want to test 
under Devices and Interfaces.

2. Select Test. If you are using NI-DAQmx and the test fails, a message 
explains the failure.

Step 14. Configure Channels and Tasks
A physical channel is a terminal or pin at which you can measure or 
generate an analog or digital signal. A virtual channel is a collection of 
settings that can include a name, a physical channel, input terminal 
connections, the type of measurement or generation, and scaling 
information. In Traditional NI-DAQ and earlier versions, configuring 
virtual channels is an optional way to record which channels are being used 
for different measurements. In NI-DAQmx, virtual channels are integral to 
every measurement.

In Traditional NI-DAQ, you configure virtual channels using MAX. In 
NI-DAQmx, you can configure virtual channels with the DAQ Assistant, 
which you can open from MAX or your application software. You also can 
configure virtual channels with the NI-DAQmx API in your application 
program. 
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A task, an important new concept for NI-DAQmx, is a collection of one 
or more virtual channels with timing, triggering, and other properties. 
Conceptually, a task represents a measurement or generation you want to 
perform. You can set up and save all of the configuration information in a 
task and use the task in an application. 

In NI-DAQmx, you can configure virtual channels as part of a task or 
separate from a task. Virtual channels created inside a task are local 
channels. Virtual channels defined outside a task are global channels. You 
can create global channels in MAX or in your application software and then 
save them in MAX. You can use global channels in any application or add 
them to a number of different tasks. If you modify a global channel, the 
change affects all tasks in which you reference that global channel. In most 
cases, it is simpler to use local channels. 

Configure a Task in NI-DAQmx
Configure tasks with the DAQ Assistant when you use NI-DAQmx. You 
must have version 7.0 of an NI application software package to create tasks 
and channels with the DAQ Assistant. 

• In MAX, right-click Data Neighborhood and select Create New. 
In the Create New window, select NI-DAQmx Task and click Next.

• You also can open the DAQ Assistant directly from within 
NI application software: 

– In LabVIEW, there are several ways to open the DAQ Assistant:

• Drop the DAQ Assistant Express VI from the Express Input 
palette, as described in the Getting Started with LabVIEW 
document. 

• You also can use the DAQmx Task Name control to open the 
DAQ Assistant. Right-click the control and select New Task. 
The Taking an NI-DAQmx Measurement in LabVIEW tutorial 
has step-by-step instructions on how to create a task from the 
DAQmx Task Name control and generate code for the task. 
In LabVIEW, select Help»Taking an NI-DAQmx 
Measurement to open the tutorial.

– In LabWindows™/CVI™, select Tools»Create/Edit DAQmx 
Tasks. 

– In Measurement Studio, open Visual Studio .NET and select 
Project»Add New Item to open the Add New Item dialog box. 
In the Categories pane, select Measurement Studio»Assistants. 
In the Templates pane, select DAQmx Task Class.

The DAQ Assistant opens.
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Follow the online instructions to create a new task. 

1. Select an I/O type, such as analog input.

2. Select the measurement or generation to perform.

3. Choose the sensor to use, if applicable.

4. Select the channels to add to the task. You can add global channels to 
the task or select physical channels from which to create local channels 
in the task.

5. Configure measurement-specific settings, timing, and triggering, 
if necessary. 

6. Save the task.

• If you opened the DAQ Assistant from LabVIEW or 
LabWindows/CVI, click OK. 

• If you opened the DAQ Assistant from Measurement Studio, 
select File»Save. 

You now can use the task in an application. Refer to the DAQ Assistant 
Help or application software documentation for more information about 
using a task or generating code.
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Configure Global Channels for NI-DAQmx
Configure global channels with the DAQ Assistant when you use 
NI-DAQmx.

• In MAX, right-click Data Neighborhood and select Create New. 
In the Create New window, select NI-DAQmx Global Channel and 
click Next.

• You also can open the DAQ Assistant directly from within 
LabVIEW 7.0, LabWindows/CVI 7.0, or Measurement Studio 7.0. 

– In LabVIEW, use the DAQmx Global Channel control to open the 
DAQ Assistant. Right-click the control and select New Channel 
(DAQ Assistant).

– In LabWindows/CVI or Measurement Studio, you must first 
create a task as previously described. In the DAQ Assistant, click 
Add Existing DAQmx Global Channels to add global channels 
to your task. 

The DAQ Assistant opens. Follow the online instructions to create a new 
global channel.

1. Select an I/O type, such as analog input. 

2. Select the measurement or generation to perform. 

3. Choose the sensor to use, if applicable. 

4. Select the physical channels to use. 

5. Configure measurement-specific settings. 

6. Save the task.

• If you opened the DAQ Assistant from LabVIEW or 
LabWindows/CVI, click OK. 

• If you opened the DAQ Assistant from Measurement Studio, 
select File»Save. 

You now can use the global channel in an application or add the global 
channel to a task. Refer to the DAQ Assistant Help or application software 
documentation for more information about using a channel or generating 
code.
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Configure Virtual Channels for Traditional NI-DAQ
When you use Traditional NI-DAQ, configure virtual channels in MAX. 

1. In MAX, right-click Data Neighborhood and select Create New. 

2. Select Traditional NI-DAQ Virtual Channel in the Create New 
window and click Finish. The Create New Channel wizard opens. 

3. Follow the instructions in the Create New Channel wizard to create a 
new channel. For additional information about configuring different 
channel types, refer to the Measurement & Automation Explorer Help 
for Traditional NI-DAQ.

Getting Started Developing an Application

Examples
Each API includes a collection of programming examples to help you get 
started developing an application. You can modify example code and save 
it in an application. You can use examples to develop a new application or 
add example code to an existing application.
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To locate LabVIEW and LabWindows/CVI examples, open the National 
Instruments Example Finder.

• In LabVIEW, select Help»Find Examples.

• In LabWindows/CVI, select Help»NI Example Finder.

Measurement Studio, Visual Basic, and ANSI C examples are in the 
following directories:

• NI-DAQmx examples for Measurement Studio-supported languages 
are in the following directories:

– MeasurementStudio\VCNET\Examples\DAQmx 

– MeasurementStudio\DotNET\Examples\DAQmx

• Traditional NI-DAQ examples for Visual Basic are in the following 
directories:

– The NI-DAQ\Examples\Visual Basic with Measurement 
Studio directory contains a link to the ActiveX control examples 
for use with Measurement Studio.

– The NI-DAQ\Examples\VBasic directory contains the 
examples not associated with Measurement Studio.

• NI-DAQmx examples for ANSI C are in the NI-DAQ\Examples\
DAQmx ANSI C Dev directory.

• Traditional NI-DAQ examples for ANSI C are in the NI-DAQ\
Examples\VisualC directory.

For additional examples, refer to ni.com/zone.

Information about Measurement Applications and Devices
Each application software package and driver includes information about 
writing applications for taking measurements and controlling measurement 
devices. The following references to documents assume you have 
NI-DAQ 7.0, and where applicable, version 7.0 of the NI application 
software.

LabVIEW
If you are a new user, complete the Getting Started with LabVIEW 
to get acquainted with LabVIEW. Select Start»Programs»National 
Instruments»LabVIEW»Search the LabVIEW Bookshelf. 

The LabVIEW Measurements Manual contains API overviews of 
Traditional NI-DAQ and NI-DAQmx, and describes measurement 
concepts. Select Start»Programs»National Instruments»LabVIEW»
Search the LabVIEW Bookshelf.
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The Taking an NI-DAQmx Measurement in LabVIEW help tutorial has 
step-by-step instructions on how to set up a measurement in LabVIEW and 
describes key new NI-DAQmx features and concepts such as the DAQ 
Assistant and tasks. Select Help»Taking an NI-DAQmx Measurement in 
LabVIEW to open the tutorial.

The LabVIEW Traditional NI-DAQ VI Reference Help and the LabVIEW 
NI-DAQmx VI Reference Help describe the LabVIEW VIs and properties. 
In LabVIEW, select Help and the LabVIEW VI reference help for the 
NI-DAQ API you are using. 

LabWindows/CVI
The Data Acquisition Library book of the main LabWindows/CVI Help 
contains API overviews, measurement concepts, and function references 
for Traditional NI-DAQ and NI-DAQmx. In LabWindows/CVI, select 
Help»Contents.

Measurement Studio
The NI Measurement Studio Help contains the NI-DAQmx API overview, 
measurement tasks and concepts, and function reference. This help file is 
integrated into the Visual Studio .NET documentation. In Visual Studio 
.NET, select Help»Contents.

The Measurement Studio Reference contains the Traditional NI-DAQ API 
overview, measurement concepts, and function reference. In Visual Studio 
.NET, select Measurement Studio»Measurement Studio Reference. 

ANSI C without NI Application Software
The Traditional NI-DAQ User Manual and the NI-DAQmx Help contain 
API overviews. The NI-DAQmx Help also contains general information 
about measurement concepts. The Traditional NI-DAQ C Reference Help 
and the NI-DAQmx C Reference Help describe the C functions and 
attributes. Select Start»Programs»National Instruments»NI-DAQ and 
the document title for the NI-DAQ API you are using.

.NET Languages without NI Application Software
The NI Measurement Studio Help contains the NI-DAQmx API overview, 
measurement tasks and concepts, and function reference. This help is 
integrated into the Visual Studio .NET documentation. In Visual Studio 
.NET, select Help»Contents.

Note If you use a .NET language without Visual Studio .NET, you might not be able to 
view the NI Measurement Studio Help.
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Device Documentation
NI-DAQ 7.0 includes the Device Document Browser, which contains 
online documentation for supported DAQ, SCXI, and switch devices, such 
as help files describing device pinouts, features, and operation, and PDF 
files of the printed device documents. You can find, view, and/or print the 
documents for each device using the Device Document Browser at any 
time by inserting the CD. After installing the Device Document Browser, 
device documents are accessible from Start»Programs»National 
Instruments»NI-DAQ»Browse Device Documentation. 

SCXI and Switch Multi-Chassis Configurations
The SCXI-1346 Shielded Multi-Chassis Cable Installation Guide contains 
setup instructions for developing SCXI and switch multi-chassis 
applications.

Switch
The NI Switches Help contains technical and programming support for the 
switch module and the NI-SWITCH instrument driver.

The NI-SWITCH Instrument Driver Quick Reference Guide contains an 
API overview and function/VI overview.

Training Courses
If you need more help getting started developing an application with 
NI products, NI offers training courses. To enroll in a course or obtain 
a detailed course outline, refer to ni.com/training.

Technical Support
For additional support, refer to ni.com/support or ni.com/zone. 
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Troubleshooting
My chassis power is on, and my modules are configured for 
multiplexed mode, but I am not getting good data on any channel. 
What is causing this problem?

The SCXI chassis has backplane fuses, fused at 1.5 A on the SCXI-1000 
chassis and at 4 A on the SCXI-1001 chassis. One or both of the fuses might 
be blown.

On the SCXI-1000, the backplane fuses are located behind the fan. On the 
SCXI-1001, the backplane fuses are located behind the right-hand fan, near 
the power entry module, as viewed from the rear of the chassis.

Complete the following steps to check or replace fuses.

1. Power off the chassis and remove the power cord.

2. Remove the four screws that secure the fan and filter to the rear of the 
chassis. When removing the last screw, be careful to hold the fan to 
avoid breaking the fan wires.

3. The fuse marked with a copper + on the backplane is for the positive 
analog supply, and the fuse marked with a copper – is for the negative 
analog supply. To check whether a fuse is blown, connect an ohmmeter 
across the leads. If the reading is not 0 Ω, replace the fuse.

4. Using needle-nose pliers, carefully extract the fuse.

5. Take a new fuse and bend its leads so the component is 12.7 mm 
(0.5 in.) long—the dimension between the fuse sockets—and clip the 
leads to a length of 6.4 mm (0.25 in.).

6. Using needle-nose pliers, insert the fuse into the socket holes.

7. Repeat, if necessary, for the other fuse.

8. Align the fan and filter with the fan holes, making sure that the label 
side of the fan is face down. Reinstall the four screws and make sure 
the assembly is secure.

My chassis worked fine until I inadvertently removed and reinserted a 
module while the chassis was on. Now my chassis does not power on. 
What can I do?

SCXI modules are not hot swappable, so you may have blown a fuse. 
If replacing the fuse does not correct the problem, you may have damaged 
the digital bus circuitry or the SCXI module. Contact NI technical support 
at ni.com/support for assistance.
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MAX will not recognize my chassis when I perform a test? What can 
I do?

Check the following items:

• Verify the chassis is powered on.

• Verify the chassis is correctly cabled to a DAQ device. If more than one 
DAQ device is installed in your PC, verify the device selected for 
Chassis Communicator is actually connected to the chassis.

• Check to see if any backplane pins were bent during installation of 
modules.

• Verify correct placement and configuration of the modules. If you did 
not auto-detect modules, modules installed in the chassis may not be 
configured in software. Alternately, modules configured in software 
might not match the ones installed in the chassis.

Can I programmatically detect whether or not my chassis is 
powered on?

Not exactly. You can determine whether or not you can communicate with 
configured modules through SCXI_ModuleID_Read in NI-DAQ or using 
a LabVIEW VI that you can obtain from ni.com/express by entering the 
info code rdtscp.
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Dans ce document, on suppose que vous avez déja installé, configuré et 
testé une carte d’acquisition de données (DAQ). Si ce n’est pas le cas, 
suivez les instructions du Guide de démarrage DAQ pour NI-DAQ 7.0 
fourni avec la carte DAQ avant de continuer. Ce document ne concerne pas 
les châssis PXI, les châssis PXI combo, le châssis SCXI-1000DC, les 
modules SCXI de commutation, les système multi-châssis ni les opérations 
en mode parallèle, quel que soit le module. Reportez-vous à la 
documentation du module, du châssis ou des câbles d’adaptation pour 
obtenir des informations sur ces sujets. Si vous installez un module SCXI 
de commutation, reportez-vous au NI Switches Getting Started Guide.
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Conventions
Les conventions suivantes sont utilisées dans ce manuel.

» Le symbole » vous dirige vers les éléments de menu emboîtés et les options 
de boîtes de dialogue donnant lieu à une action finale. La séquence 
Fichier»Mise en page»Options vous invite à cliquer sur le menu déroulant 
Fichier, à sélectionner l’élément Mise en page, puis Options dans la 
dernière boîte de dialogue.

Cette icône signale une remarque qui vous donne des informations 
importantes.

Cette icône signale un avertissement qui vous indique les précautions à 
prendre pour éviter des dégradations, des pertes de données ou un blocage 
du système.

italique Le texte en italique signale les variables, la mise en valeur, une référence 
croisée ou une introduction à un concept clé. Cette police indique aussi un 
texte qui est substituable par un mot ou une valeur que vous devez fournir.

gras Le texte en gras signale les éléments que vous devez sélectionner ou sur 
lesquels vous devez cliquer dans le logiciel, par exemple les éléments de 
menus et les options de boîtes de dialogue.

monospace Cette police signale du texte ou des caractères que vous devez saisir à partir 
du clavier, des sections de code, des exemples de programmation et de 
syntaxe. Cette police est aussi utilisée pour les noms propres d’unités de 
disque, de chemins, de répertoires, de programmes, de sous-programmes, 
de périphériques, de fonctions, d’opérations, de méthodes, de variables, 
de fichiers et d’extensions et d’extraits de code.
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Présentation du système de mesure
La figure 1 représente une vue d’ensemble du système de mesure, illustrant 
le chemin depuis le phénomène physique réel jusqu’à votre application 
de mesure. Les composants de conditionnement du signal utilisent des 
capteurs et des transducteurs pour mesurer des signaux qui sont analysés 
et présentés grâce à l’application logicielle.

Figure 1.  Vue d’ensemble du système de mesure
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Étape 1. Déballer le module et les accessoires
Votre module est livré dans un sachet antistatique pour éviter les 
dommages électrostatiques. Ces dommages peuvent abîmer plusieurs 
composants du module.

Mise en garde Ne touchez jamais les broches des connecteurs.

Pour vous prémunir de tels dommages, respectez les précautions suivantes :

• Utilisez un ruban de mise à la masse ou tenez un objet en contact avec 
la masse pour devenir vous-même une référence à la masse. 

• Mettez en contact le sachet antistatique avec la partie métallique du 
châssis avant de sortir le module du sachet. 

Sortez le module de son sachet. Examinez les composants pour repérer tout 
signe d’endommagement. Contactez NI si le module apparaît endommagé 
de quelque façon que ce soit. N’installez jamais un module endommagé 
dans un châssis. 

Conservez le module dans le sachet antistatique quand il n’est pas utilisé.

Pour obtenir des informations de conformité et de sécurité, reportez-vous à 
la documentation du périphérique.
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Étape 2. Vérifier les composants
Assurez-vous d’avoir les éléments de base.

Étape 3. Configurer le châssis

Mise en garde Respectez les instructions de précaution contre les dommages 
électrostatiques avant d’installer le matériel.

1. Éteignez le châssis hors tension et débranchez-le.

2. Configurez les interrupteurs d’adresse du châssis sur la position off. 
Sur la figure suivante, tous les interrupteurs sont sur la position off.

Remarque Les anciens châssis disposent de cavaliers à l’intérieur de la face-avant au lieu 
d’interrupteurs d’adresse. Les anciens châssis ont également des fusibles et une sélection 
de l’alimentation AC différents. Reportez-vous à la documentation du châssis pour obtenir 
de plus amples informations.

1 Accessoires bloc de connexion ou TBX (facultatifs)
2 Modules SCXI
3 Châssis SCXI-1000 ou SCXI-1001
4 Cordon d’alimentation du châssis

5 Connecteur (cable blindé et connecteur 
d’adaptation)

6 Périphérique DAQ
7 Ordinateur

1 2 3 4

C 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 C

V 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 V

SCXI

1140 

SCXI

1140 

®

MAINFRAME 

SCXI

5 6 7
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3. Vérifiez que les paramètres d’alimentation sont correctement définis 
(100, 120, 220, ou 240 VAC).

4. Connectez le cordon d’alimentation.

1 Interrupteur d’alimentation 
du châssis

2 Interrupteurs d’adresse du châssis

3 Configuration de l’alimentation 
du châssis

4 Prise du cordon d’alimentation

1

3

2

4
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Étape 4. Installer les modules

Mise en garde Assurez-vous que le châssis n’est pas sous tension.

1. Insérez tous les modules dans le châssis.

2. Vissez les modules à la main.
 

Étape 5. Ajouter les blocs de connexion
Placez les blocs de connexion sur la face avant des modules. Reportez-vous 
à la page ni.com/products pour connaître les combinaisons de modules 
et blocs de connexion possibles. Reportez-vous au guide d’installation de 
l’accessoire TBX si vous utilisez un adaptateur de ce type.

1 Vis moletées 2 Module

®

5
4
3
2
1

1

1

2
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Étape 6. Connecter les capteurs
Câblez des capteurs aux terminaux des blocs de connexion ou accessoires. 

• Reportez-vous à la documentation du module ou de l’accessoire pour 
obtenir des informations sur la connexion des signaux. 

• Si l’un des modules du système SCXI dispose d’interrupteurs ou de 
cavaliers de configuration, reportez-vous au manuel Getting Started 
with SCXI pour obtenir plus d’informations sur la configuration 
du matériel.

• Reportez-vous aux documents suivants pour plus d’informations sur 
les capteurs :

– Si vous utilisez des capteurs, visitez ni.com/sensors.

– Si vous utilisez LabVIEW, reportez-vous au LabVIEW 
Measurements Manual livré avec LabVIEW ou disponible sur 
ni.com/manuals. 

– Si vous utilisez un autre logiciel d’application, reportez-vous à 
NI-DAQmx Help pour obtenir plus d’information sur les mesures 
courantes. Accédez au fichier d’aide en sélectionnant 
Démarrer»Programmes»National Instruments»NI-DAQ»
NI-DAQmx Help.

1 Modules avec bloc de connexion installés
2 Mise en place d’un bloc de connexion sur un module SCXI
3 Faces-avant de modules SCXI

®
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3
2
1
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Étape 7. Connecter les modules au périphérique DAQ
1. Si nécessaire, mettez en place l’adaptateur de câble.

• Si vous avez un système contenant plusieurs modules, déterminez 
celui qui apparaît en premier dans la liste suivante. Fixez 
l’adaptateur de câble au connecteur arrière de ce module SCXI. 

– SCXI-1520, SCXI-1530, SCXI-1531, SCXI-1540, 
SCXI-1581, SCXI-1140

– SCXI-1102, SCXI-1102/B/C, SCXI-1104/C, SCXI-1112, 
SCXI-1125, SCXI-1126, SCXI-1141, SCXI-1142, 
SCXI-1143

– SCXI-1100, SCXI-1120/D, SCXI-1121, SCXI-1122

– SCXI-1124, SCXI-116x

• Si vous n’avez qu’un seul module, placez l’adaptateur de câble sur 
celui-ci.

Utilisez les vis fournies pour fixer le connecteur sur le châssis.

Mise en garde Ne forcez jamais le connecteur s’il résiste. Forcer l’adaptateur peut tordre 
les broches. 

2. Connectez une extrémité du câble au connecteur ou au module et 
l’autre extrémité au périphérique DAQ. Notez quel est le module SCXI 
connecté au périphérique DAQ, vous aurez besoin de cette information 
par la suite.

Étape 8. Mettre le châssis SCXI sous tension
L’interrupteur d’alimentation du châssis est montré à l’étape 3.

Étape 9. Lancer Measurement & Automation Explorer 
(MAX)

Double-cliquez sur l’icône Measurement & Automation qui se trouve sur 
le bureau pour lancer MAX.

Remarque Reportez-vous au Hardware Installation Wizard sur ni.com/support/
install pour obtenir les instructions de configuration SCXI avec des produits des séries 
RT. Sélectionnez Hardware Configuration et cliquez sur Real-Time Configuration 
Wizard.
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Étape 10. Ajouter le châssis SCXI
1. Cliquez avec le bouton droit sur Périphériques et interfaces et 

sélectionnez Créer un nouvel objet.
 

2. Sélectionnez le châssis SCXI dans la fenêtre Créer un nouvel objet. 

Si vous utilisez plus d’une API DAQ pour contrôler le châssis dans 
votre application, ajoutez le châssis dans chaque API DAQ que vous 
utilisez.

• Si vous utilisez NI-DAQ traditionnel, sélectionnez le châssis dans 
Périphérique NI-DAQ traditionnel.

• Si vous utilisez NI-DAQmx, sélectionnez le châssis dans 
NI-DAQmx Device»NI-DAQmx SCXI Chassis.

Quand un périphérique est supporté à la fois par NI-DAQ traditionnel 
et NI-DAQmx et que ces deux drivers sont installés, le même 
périphérique apparaît avec un nom différent dans les rubriques 
“Périphériques NI-DAQ” et “NI-DAQmx Device”.

Remarque Reportez-vous au Guide de démarrage DAQ pour NI-DAQ 7.0 pour obtenir 
plus d’informations sur les jeux de fonctions (API) NI-DAQ traditionnel et NI-DAQmx.

3. Cliquez sur Terminer lorsque vous avez fait votre sélection. Une 
fenêtre de configuration apparaît. Reportez-vous à l’Étape 11. 
Configurer le châssis pour obtenir plus d’informations.

Si votre périphérique n’apparaît pas automatiquement, appuyez sur <F5> 
pour rafraîchir l’affichage dans MAX. Si votre périphérique n’est toujours 
pas reconnu, reportez-vous à la page ni.com/support/install pour 
obtenir des informations de dépannage.

Si vous utilisez NI-DAQ traditionnel, il existe une autre méthode pour 
ajouter un châssis SCXI. Cliquez avec le bouton droit sur Périphériques et 
interfaces»Périphériques NI-DAQ traditionnel et sélectionnez Ajouter 
un châssis SCXI.
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Si vous utilisez NI-DAQmx, il existe une autre méthode pour ajouter 
un châssis SCXI. Cliquez avec le bouton droit sur Périphériques et 
interfaces»NI-DAQmx Devices et sélectionnez Create New NI-DAQmx 
Device. Sélectionnez NI-DAQmx SCXI Chassis et choisissez le châssis.

Étape 11. Configurer le châssis
L’opération de configuration n’est pas la même suivant le driver DAQ 
que vous utilisez pour contrôler le châssis—NI-DAQ traditionnel ou 
NI-DAQmx.

NI-DAQ traditionnel
Si vous utilisez NI-DAQ traditionnel, suivez les étapes suivantes pour 
configurer le châssis SCXI, comme illustré sur les figures ci-après.

1. Sélectionnez un ID pour le châssis SCXI. L’ID peut prendre n’importe 
quelle valeur entière entre 1 et 3200. Utilisez cet ID pour identifier le 
châssis dans votre application.

2. Entrez la configuration d’adresse du châssis. L’adresse du châssis peut 
être n’importe quelle valeur entre 0 et 31. Assurez vous que la valeur 
que vous définissez correspond à la valeur des interrupteurs d’adresse 
sur le châssis SCXI. Reportez-vous à l’Étape 3. Configurer le châssis 
pour vous aider à situer les interrupteurs d’adresse du châssis. Cliquez 
sur Suivant. 

3. Choisissez si vous voulez détecter les modules SCXI automatiquement 
ou non. Cliquez sur Suivant.

21 3
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4. Sélectionnez la carte DAQ qui sert de chemin de communication entre 
le châssis et l’ordinateur. Cliquez sur Suivant.

5. Sélectionnez le module SCXI qui est câblé au périphérique de 
communication. S’il n’y a qu’un seul module dans le châssis, NI-DAQ 
le sélectionne par défaut.

6. Cliquez sur Terminer pour valider la configuration.

NI-DAQmx
Si vous utilisez NI-DAQmx, suivez les étapes suivantes pour configurer le 
châssis, comme illustré sur les figures.

1. Sélectionnez le périphérique DAQ câblé au module de communication 
SCXI dans Chassis Communicator. Si MAX ne détecte qu’une seule 
carte DAQ, elle est sélectionnée par défaut et cette option est grisée.

2. Sélectionnez le numéro d’emplacement du module connecté au 
périphérique de communication avec le châssis dans Communicating 
SCXI Module Slot.

3. Entrez la configuration d’adresse du châssis dans Chassis Address. 
Assurez-vous que la configuration de l’adresse correspond à la 
configuration sur le châssis SCXI.

4. Choisissez si vous voulez détecter les modules SCXI automatiquement 
ou non. Si vous ne sélectionnez pas la détection automatique des 
modules, MAX désactive la sélection du numéro d’emplacement du 
module de communication.

Mise en garde La détection automatique des modules peut mettre les modules dans un état 
inconnu ou non désiré. Déconnectez tous les périphériques connectés pour lesquels une 
détection automatique pourrait poser problème.

4 5

6
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5. Cliquez sur Save.

6. La fenêtre SCXI Chassis Configuration s’ouvre. L’onglet Modules 
est sélectionné par défaut. Si vous n’avez pas choisi la détection 
automatique des modules, sélectionnez un module SCXI dans la liste 
déroulante Modules. Assurez-vous que le module corresponde au bon 
emplacement.

7. MAX génère un nom par défaut dans le champ Device Name. 
Pour changer ce nom, cliquez dans le champ et entrez un ID 
alphanumérique unique pour le module SCXI.

8. Si vous utilisez un accessoire connecté au module, sélectionnez-le 
dans Accessory.

9. Cliquez sur Details pour accéder à des options de configuration 
supplémentaires. Reportez-vous à l’Étape 12. Configurer les modules 
SCXI pour obtenir plus d’informations.

10. Si vous devez changer certains paramètres de configuration du châssis, 
cliquez sur l’onglet Chassis. La plupart des utilisateurs n’ont pas 
besoin de changer la configuration du châssis.

11. Cliquez sur OK pour valider et enregistrer les paramètres pour ce 
châssis.

1

2

3

4
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Remarque Vous ne pouvez pas enregistrer la configuration du châssis avant d’avoir 
terminé d’entrer les informations d’un module. Un message en haut de la fenêtre “SCXI 
Chassis Configuration” vous informe de l’état de la configuration. Vous ne pouvez pas 
enregistrer s’il s’agit d’un message d’erreur. S’il s’agit d’un message de mise en garde, 
vous pouvez enregistrer la configuration, toutefois NI vous conseille de résoudre la source 
de la mise en garde avant d’enregistrer.

Étape 12. Configurer les modules SCXI
L’opération de configuration n’est pas la même suivant le driver DAQ que 
vous utilisez pour programmer les modules – NI-DAQ traditionnel ou 
NI-DAQmx.

NI-DAQ traditionnel
Si vous utilisez NI-DAQ traditionnel, suivez les étapes suivantes pour 
configurer les modules SCXI.

1. Sélectionnez le châssis dans la rubrique Périphériques et interfaces»
Périphériques NI-DAQ traditionnel.

2. Cliquez avec le bouton droit sur un numéro d’emplacement et 
choisissez Propriétés.

610 7 8 9

11
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3. L’onglet Généralités est sélectionné par défaut. Sélectionnez le 
périphérique DAQ connecté au module dans Connecté à. Cochez la 
case située en dessous si le périphérique DAQ contrôle le châssis.

4. Pour certains modules vous devez définir le mode de 
fonctionnement – mode mutliplexé ou mode parallèle. Sélectionnez 
le mode dans Mode de fonctionnement.
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5. Certains modules disposent de filtres et/ou de gain que vous pouvez 
sélectionner par logiciel pour chaque voie. Les paramètres disponibles 
dépendent du type de module. Cliquez sur l’onglet Voie, s’il est 
disponible. Sélectionnez les paramètres dans les différents champs 
affichés.

6. Cliquez sur l’onglet Accessoire. Sélectionnez un périphérique 
compatible dans la liste déroulante Accessoire.

7. Cliquez sur OK pour valider la configuration.
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NI-DAQmx
Si vous utilisez NI-DAQmx, suivez les étapes suivantes pour configurer les 
modules. Vous pouvez vous affranchir de cette étape si vous utilisez une 
seule carte MIO avec votre système SCXI en mode multiplexé.

1. Sélectionnez le châssis dans la rubrique Périphériques et 
interfaces»NI-DAQmx Devices.

2. Cliquez avec le bouton droit sur le module et choisissez Properties.

Remarque Vous pouvez également accéder aux propriétés du module en sélectionnant 
l’onglet Modules dans la fenêtre “SCXI Chassis Configuration” et en cliquant sur Details.

3. Certains modules SCXI disposent de paramètres à définir avec des 
cavaliers. Si vous configurez un tel module, cliquez sur l’onglet 
Jumpers et entrez les paramètres sélectionnés au niveau matériel.
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4. Cliquez sur l’onglet Accessory.

5. Pour changer l’accessoire sélectionné pendant la configuration du 
châssis, sélectionnez un accessoire de module dans la liste déroulante 
Accessory.

6. Cliquez sur Configure pour éditer les paramètres de l’accessoire. 
Certains accessoires n’ont pas de paramètre. Reportez-vous à la 
documentation de l’accessoire pour obtenir de plus amples 
informations.
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7. Si vous utilisez un module d’entrées analogiques, cliquez sur l’onglet 
Cabling.

Remarque Il n’est pas nécessaire de modifier les informations de l’onglet “Cabling” 
lorsque vous utilisez le mode multiplexé standard. Si vous utilisez le mode de 
fonctionnement parallèle, une configuration multi-châssis ou une autre configuration 
particulière, définissez les options sur l’onglet Cabling.

8. Sélectionnez le périphérique DAQ connecté au module SCXI dans la 
liste déroulante Which device connects to this module?. En général, 
le périphérique sélectionné et le “module digitizer” (numériseur) sont 
les mêmes.

9. Sélectionnez un périphérique DAQ dans la liste déroulante Module 
Digitizer. Ce périphérique peut être différent de celui sélectionné dans 
la liste déroulante Which device connects to this module?.

10. Si vous utilisez le mode de fonctionnement parallèle, cliquez sur 
Parallel Mode.

11. Si le module est installé dans un châssis cascadé avec d’autres châssis, 
sélectionnez un numéro d’indice dans la liste déroulante Multichassis 
Daisy-Chain Index. La liste déroulante n’apparaît que si deux châssis 
au moins ont été ajoutés et enregistrés.

12. Cliquez sur OK.

Pour obtenir plus d’informations sur les propriétés des modules que vous 
pouvez configurer par logiciel, reportez-vous à l’Aide de Measurement & 
Automation Explorer pour la version traditionnelle de NI-DAQ ou à 
Measurement & Automation Explorer Help for NI-DAQmx. Pour accéder à 
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ces fichier d’aide depuis MAX, sélectionnez Aide»Sujets de l'aide»
NI-DAQ traditionnel ou Aide»Sujets de l’aide»NI-DAQmx.

Étape 13. Tester le châssis
Vérifiez que le châssis est reconnu par MAX.

1. Cliquez avec le bouton droit sur le nom du châssis dans l’API DAQ que 
vous voulez dans la rubrique “Périphériques et interfaces”.

2. Sélectionnez Test. Lorsque vous utilisez NI-DAQmx, si le test échoue, 
un message vous explique la raison de l’échec.

Étape 14. Configurer les voies et les tâches.
Une voie physique est un terminal ou broche sur laquelle vous pouvez 
mesurer ou générer un signal analogique ou numérique. Une voie virtuelle 
est un ensemble de propriétés pouvant inclure un nom, une voie physique, 
un type de connexion au terminal, le type de mesures (acquisition ou 
génération) et des informations de mise à l’échelle. Dans NI-DAQ 
traditionnel et les versions précédentes, la configuration des voies virtuelles 
est une manière possible d’enregistrer les voies utilisées pour différentes 
mesures. Dans NI-DAQmx, les voies virtuelles font partie intégrante de la 
mesure.

Dans NI-DAQ traditionnel, vous configurez les voies virtuelles avec MAX. 
Dans NI-DAQmx, vous pouvez configurer les voies virtuelles avec 
l’Assistant DAQ, que vous pouvez ouvrir avec MAX ou avec votre logiciel 
d’applications. Vous pouvez également configurer les voies virtuelles dans 
votre programme avec l’API de NI-DAQmx. 
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Une tâche est un ensemble d’une ou plusieurs voies virtuelles qui inclut 
l’horloge, le déclenchement et d’autres propriétés. C’est un concept 
nouveau et important dans NI-DAQmx. Fondamentalement, une tâche 
représente la mesure ou la génération que vous voulez réaliser. Vous pouvez 
définir et enregistrer toutes les informations de configuration dans une 
tâche et l’utiliser dans une application. 

Dans NI-DAQmx, les voies virtuelles peuvent être définies comme faisant 
partie d’une tâche ou être configurées séparement de celle-ci. Les voies 
virtuelles créées à l’intérieur d’une tâche sont des voies locales. Les voies 
virtuelles créées à l’extérieur d’une tâche sont des voies globales. Vous 
pouvez créer des voies globales depuis MAX ou depuis votre application 
logicielle puis les enregistrer sous MAX. Vous pouvez utiliser les voies 
globales dans n’importe quelle application ou les ajouter à d’autres tâches. 
Si vous modifiez une voie globale, les changements affectent toutes les 
tâches dans lesquelles cette voie est utilisée. Dans la plupart des cas, il est 
plus simple d’utiliser les voies locales. 

Configurer une tâche dans NI-DAQmx
Sous NI-DAQmx, les tâches se configurent avec l’Assistant DAQ. Vous 
devez avoir la version 7.0 d’un logiciel d’application NI pour créer des 
tâches et des voies avec l’Assistant DAQ. 

• Dans MAX, cliquez avec le bouton droit sur Voisinage de données et 
sélectionnez Créer un nouvel objet. Dans la fenêtre Créer un nouvel 
objet, sélectionnez NI-DAQmx Task puis cliquez sur Suivant.

• Vous pouvez également ouvrir directement l’Assistant DAQ à partir de 
votre logiciel d’applications NI.

– Dans LabVIEW, de nombreuses méthodes permettent d’ouvrir 
l’Assistant DAQ :

• Déposez le VI Express “Assistant DAQ” à partir de la palette 
“Entrée” des VIs Express, comme expliqué dans le manuel 
Initiation à LabVIEW. 

• Vous pouvez également utiliser la commande Nom de tâche 
DAQmx pour ouvrir l’Assistant DAQ. Cliquez avec le bouton 
droit sur la commande et sélectionnez Nouvelle tâche 
(Assistant DAQ). Le fichier d’aide Taking an NI-DAQmx 
Measurement in LabVIEW contient les instructions pas à pas 
pour créer une tâche à partir de la commande Nom de tâche 
DAQmx et générer le code associé à la tâche. Dans 
LabVIEW, sélectionnez Aide»Taking an NI-DAQmx 
Measurement pour ouvrir le tutorial.

– Dans LabWindows™/CVI™, sélectionnez Tools»Create/Edit 
DAQmx Tasks. 
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– Dans Measurement Studio, ouvrez Visual Studio .NET et 
sélectionnez Project»Add New Item pour ouvrir la boîte de 
dialogue Add New Item. Dans la sous-fenêtre Categories, 
sélectionnez Measurement Studio»Assistants. Dans la 
sous-catégorie Templates, sélectionnez DAQmx Task Class.

L’Assistant DAQ s’ouvre.

Suivez les instructions en ligne pour créer une nouvelle tâche. 

1. Choisissez un type d’E/S, par exemple une entrée analogique 
(Analog Input).

2. Sélectionnez la mesure ou la génération à réaliser.

3. Choisissez, si nécessaire, le capteur à utiliser.

4. Sélectionnez les voies à ajouter dans la tâche. Vous pouvez ajouter des 
voies globales dans la tâche ou sélectionner des voies physiques à 
partir desquelles vous créez des voies locales dans la tâche.

5. Si nécessaire, configurez des paramètres de mesures spécifiques, 
l’horloge et le déclenchement. 

6. Enregistrez la tâche.

• Si vous avez ouvert l’Assistant DAQ à partir de LabVIEW ou de 
LabWindows/CVI, cliquez sur OK. 

• Si vous avez ouvert l’Assistant DAQ à partir de Measurement 
Studio, sélectionnez File»Save. 
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Vous pouvez maintenant utiliser la tâche dans une application. 
Reportez-vous à DAQ Assistant Help ou à la documentation du logiciel 
pour obtenir davantage d’informations sur la manière d’utiliser une tâche 
ou de générer du code.

Configurer des voies globales pour NI-DAQmx
Lorsque vous utilisez NI-DAQmx, configurez les voies globales avec 
l’Assistant DAQ.

• Dans MAX, cliquez avec le bouton droit sur Voisinage de données et 
sélectionnez Créer un nouvel objet. Dans la fenêtre Créer un nouvel 
objet, sélectionnez NI-DAQmx Global Channel puis cliquez sur 
Suivant.

• Vous pouvez également ouvrir l’Assistant DAQ directement à partir de 
LabVIEW 7.0, LabWindows/CVI 7.0, ou Measurement Studio 7.0 :

– Dans LabVIEW, utilisez la commande Nom de tâche DAQmx 
pour ouvrir l’Assistant DAQ. Cliquez avec le bouton droit sur la 
commande et sélectionnez Nouvelle voie DAQ (Assistant DAQ).

– Dans LabWindows/CVI ou Measurement Studio, vous devez au 
préalable créer une tâche, comme expliqué précédemment. Dans 
l’Assistant DAQ, cliquez sur Add Existing DAQmx Global 
Channels pour ajouter des voies globales dans votre tâche. 

L’Assistant DAQ s’ouvre. Suivez les instructions en ligne pour créer une 
nouvelle voie globale.

1. Choisissez un type d’E/S, par exemple une entrée analogique 
(Analog Input). 

2. Sélectionnez la mesure ou la génération à réaliser. 

3. Choisissez, si nécessaire, le capteur à utiliser. 

4. Sélectionnez les voies physiques à utiliser. 

5. Configurez les paramètres de mesure spécifiques. 

6. Enregistrez la tâche.

• Si vous avez ouvert l’Assistant DAQ à partir de LabVIEW ou de 
LabWindows/CVI, cliquez sur OK. 

• Si vous l’avez ouvert à partir de Measurement Studio, 
sélectionnez File»Save. 

Vous pouvez maintenant utiliser la voie globale dans une application ou 
l’ajouter dans une tâche. Reportez-vous à DAQ Assistant Help ou à la 
documentation du logiciel pour davantage d’informations sur la manière 
d’utiliser une voie ou de générer du code.
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Configurer des voies virtuelles pour NI-DAQ traditionnel
Lorsque vous utilisez NI-DAQ traditionnel, configurez les voies virtuelles 
dans MAX.

1. Dans MAX, cliquez avec le bouton droit sur Voisinage de données et 
sélectionnez Créer un nouvel objet. 

2. Sélectionnez Voie Virtuelle et cliquez sur Terminer. L’assistant de 
création d’une nouvelle voie s’ouvre. 

3. Suivez les instructions de cet assistant pour créer une nouvelle voie. 
Pour obtenir des informations complémentaires sur la manière de 
configurer les différents types de voies, reportez-vous à l’Aide de 
Measurement & Automation Explorer pour la version traditionnelle 
de NI-DAQ.

Conseils pour le développement d’une application

Exemples
Chaque API inclut un ensemble d’exemples de programmation vous 
permettant de démarrer le développement d’une application. Vous pouvez 
modifier le code d’un exemple et l’enregistrer en dans une nouvelle 
application. Vous pouvez utiliser les exemples pour développer une 
nouvelle application ou ajouter le code des exemples dans une application 
existante.
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Pour trouver des exemples LabVIEW ou LabWindows/CVI, ouvrez l’Outil 
de recherche d’exemples National Instruments.

• Dans LabVIEW, sélectionnez Aide»Recherche d’exemples.

• Dans LabWindows/CVI, sélectionnez Help»NI Example Finder.

Les exemples pour Measurement Studio, Visual Basic et en ANSI C sont 
situés dans les répertoires suivants :

• Les exemples de NI-DAQmx pour les différents langages supportés par 
Measurement Studio sont dans :

– MeasurementStudio\VCNET\Examples\DAQmx 

– MeasurementStudio\DotNET\Examples\DAQmx

• Les exemples de NI-DAQ traditionnel pour Visual Basic sont dans les 
répertoires suivants :

– Le répertoire NI-DAQ\Examples\Visual Basic with 
Measurement Studio contient un lien vers les exemples de 
contrôles ActiveX à utiliser avec Measurement Studio.

– Le répertoire NI-DAQ\Examples\VBasic contient des exemples 
non associés à Measurement Studio.

• Les exemples de NI-DAQmx pour le langage ANSI C sont dans le 
répertoire NI-DAQ\Examples\DAQmx ANSI C.Dev.

• Les exemples de NI-DAQ traditionnel pour le langage ANSI C sont 
dans le répertoire NI-DAQ\Examples\VisualC.

Pour consulter d’autres exemples, visitez le site ni.com/zone.

Informations sur les périphériques et les applications de mesure
Tous les logiciels d’application et drivers sont livrés avec des informations 
sur la manière d’écrire des applications de mesure et de contrôle de 
périphériques. Les références aux documents suivantes supposent que 
NI-DAQ 7.0 et la version 7.0 du logiciel d’applications NI sont installés.

LabVIEW
Si vous êtes un nouvel utilisateur, étudiez le document Initiation à 
LabVIEW pour vous familiariser avec LabVIEW. Sélectionnez 
Démarrer»Programmes»National Instruments»LabVIEW 7.0»
Recherche dans les manuels PDF. 

Le manuel LabVIEW Measurements Manual contient une vue d’ensemble 
des APIs de NI-DAQ traditionnel et NI-DAQmx, ainsi qu’une description 
des concepts de mesures. Sélectionnez Démarrer»Programmes»
National Instruments»LabVIEW»Recherche dans les manuels PDF.
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Le tutorial de l’aide Taking an NI-DAQmx Measurement in LabVIEW 
contient des instructions pas-à-pas pour configurer une mesure avec 
LabVIEW. Il décrit aussi les nouvelles fonctionnalités clés de NI-DAQmx 
et les concepts nouveaux comme l’Assistant DAQ et les tâches. Dans 
LabVIEW, sélectionnez Aide»Taking an NI-DAQmx Measurement 
pour ouvrir le tutorial.

Les fichiers d’aide VIs d’acquisition de données de NI-DAQ traditionnel et 
DAQmx - Data Acquisitions and Functions décrivent l’ensemble des VIs et 
propriétés DAQ pour LabVIEW. Dans LabVIEW, sélectionnez Aide puis 
choisissez le fichier d’aide pour l’API de NI-DAQ que vous utilisez. 

LabWindows/CVI
La catégorie Data Acquisition Library du document LabWindows/CVI 
Help principal contient une vue d’ensemble des APIs, des concepts 
de mesure et des références des fonctions pour NI-DAQ traditionnel et 
NI-DAQmx. Dans LabWindows/CVI, sélectionnez Help»Contents.

Measurement Studio
Le document NI Measurement Studio Help contient une vue d’ensemble de 
l’API NI-DAQmx, des tâches de mesures, des concepts et des références de 
fonctions. Le fichier d’aide est intégré dans la documentation de Visual 
Studio .NET. Dans Visual Studio .NET, sélectionnez Help»Contents.

Le document Measurement Studio Reference contient une vue d’ensemble 
de l’API NI-DAQ, des concepts de mesures et des références de fonctions. 
Dans Visual Studio .NET, sélectionnez Measurement Studio»
Measurement Studio Reference.

ANSI C sans logiciel d’applications NI
Les documents Traditional NI-DAQ User Manual et NI-DAQmx Help 
contiennent une vue d’ensemble des APIs. NI-DAQmx Help contient aussi 
des informations d’ordre général sur les concepts de mesures. Les 
documents Traditional NI-DAQ Function Reference Help et NI-DAQmx C 
Reference Help décrivent l’ensemble des fonctions C et des attributs. 
Sélectionnez Démarrer»Programmes»National Instruments»NI-DAQ 
et choisissez le titre du document pour l’API de NI-DAQ que vous utilisez.

Langages .NET sans logiciel d’applications NI
Le document NI Measurement Studio Help contient une vue d’ensemble de 
l’API de NI-DAQmx, des tâches de mesure, des concepts et des références 
de fonctions. Le fichier d’aide est intégré dans la documentation de Visual 
Studio .NET. Dans Visual Studio .NET, sélectionnez Help»Contents.
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Remarque Si vous utilisez un langage .NET sans Visual Studio .NET, il se peut que vous 
ne puissiez pas ouvrir NI Measurement Studio Help.

Documentation des périphériques
NI-DAQ 7.0 inclut l’explorateur Device Document Browser, qui contient 
la documentation en ligne pour les périphériques DAQ, SCXI et les 
périphériques de commutation supportés. Il contient par exemple des 
fichiers d’aide décrivant le périphérique, ses broches, ses fonctionnalités, 
les opérations qu’il peut réaliser, et les fichiers PDF correspondant aux 
documents papiers livrés avec le périphérique. Vous pouvez trouver, 
visualiser et/ou imprimer les documents pour chaque périphérique à tout 
moment en insérant le CD. Après avoir installé l’explorateur Device 
Document Browser, les documents du périphérique sont accessibles en 
allant dans Démarrer»Programmes»National Instruments»NI-DAQ»
Browse Device Documentation. 

Configurations avec plusieurs châssis SCXI et systèmes de 
commutation
Le document SCXI-1346 Shielded Multi-Chassis Cable Adapter 
Installation Guide contient des instructions pour développer des 
applications mettant en oeuvre plusieurs châssis SCXI et systèmes de 
commutation.

Commutation
Le document NI Switches Help contient des informations techniques pour 
la programmation et le support des modules de commutation, ainsi que sur 
le driver d’instrument NI-SWITCH.

Le document NI-SWITCH Instrument Driver Quick Reference Guide 
contient une vue d’ensemble de l’API, des fonctions et des VIs.

Cours de formation
Si vous voulez être davantage aidé pour démarrer le développement d’une 
application avec les produits NI, NI offre des cours de formations. Pour 
participer à un cours, ou en connaître le contenu, visitez la rubrique 
“Événements/Formations” à l’adresse ni.com/france. 

Support Technique
Pour obtenir un complément de support, visitez les sites ni.com/zone, 
ni.com/support et ni.com/france/support, ce dernier site étant 
exclusivement en français. 
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Dépannage
Mon châssis est sous tension et mes modules configurés en mode 
multiplexé, mais je ne lis pas les données attendues, sur aucune des 
voies. Quelle peut être l’origine du problème ?

Le châssis SCXI est équipé de fusibles sur le fond de panier, capables de 
supporter 1,5 A pour le châssis SCXI-1000 et 4 A pour le châssis 
SCXI-1001. Il est possible qu’un ou que les deux fusibles soient grillés.

Sur le châssis SCXI-1000, les fusibles sont situés derrière le ventilateur. 
Sur le châssis SCXI-1001, les fusibles se trouvent derrière le ventilateur de 
droite, à côté du module d’alimentation, lorsque vous regardez depuis 
l’arrière du châssis.

Effectuez les opérations suivantes pour vérifier ou remplacer des fusibles.

1. Éteignez le châssis et débranchez le cordon d’alimentation.

2. Retirez les quatre vis qui maintiennent le ventilateur et le filtre sur la 
face arrière du châssis. Lorsque vous retirez la dernière vis, 
assurez-vous de maintenir le ventilateur pour éviter de l’endommager.

3. Le fusible signalé par un + en cuivre sur la face arrière est pour 
l’alimentation analogique positive, le fusible signalé par un – en cuivre 
sur la face arrière est pour l’alimentation analogique négative. Pour 
vérifier si un fusible a sauté, branchez un ohmètre entre les contacts. 
Si vous ne lisez pas 0 Ω, remplacez le fusible.

4. Utilisez des pinces à bec effilé pour extraire le fusible avec précaution.

5. Prenez un nouveau fusible et pliez ses branches de manière à ce que 
le composant mesure 12,7 mm (0,5 pouce) – dimension entre les 
supports du fusible – et coupez les branches à une longueur de 6,4 mm 
(0,25 pouce).

6. Utilisez des pinces à bec effilé pour insérer le fusible dans les trous 
du support.

7. Exécutez les mêmes étapes pour l’autre fusible si nécessaire.

8. Alignez le ventilateur et le filtre avec les trous, assurez-vous que le coté 
portant l’étiquette du ventilateur se trouve vers le bas. Remettez en 
place les quatre vis et vérifiez que l’ensemble est bien fixé.
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Mon châssis fonctionnait correctement jusqu’à ce que par 
inadvertance je retire et réinsère un module alors que le châssis était 
sous tension. Maintenant mon châssis ne démarre plus. Que puis-je 
faire ?

Les modules SCXI ne peuvent pas être insérés à chaud, vous avez 
probablement grillé un fusible. Si après avoir remplacé le fusible, le 
problème persiste, il est possible que vous ayez endommagé le circuit du 
bus numérique ou le module SCXI. Veuillez contacter le support technique 
National Instruments France à l’adresse ni.com/france/support.

MAX ne reconnaît pas le châssis lorsque je lance un test ? Que puis-je 
faire ?

Vérifiez les éléments suivants :

• Vérifiez que le châssis est sous tension.

• Vérifiez que le châssis est correctement connecté à la carte DAQ. 
Si vous avez plus d’une carte DAQ installée dans votre PC, vérifiez 
que le périphérique sélectionné dans Chassis Communicator ou 
Connecté à est le périphérique réellement connecté au châssis.

• Vérifiez que les broches du bus fond de panier n’ont pas été tordues 
lors de l’installation des modules.

• Vérifiez que les modules sont correctement placés et configurés. 
Si vous n’avez pas utilisé la détection automatique des modules, les 
modules installés dans le châssis ne sont peut être pas configurés au 
niveau logiciel. Il est également possible que les modules configurés 
dans le logiciel ne correspondent pas à ceux installés dans le châssis.

Puis-je savoir par programmation si mon châssis est sous tension 
ou pas ?

Pas directement. Vous pouvez savoir si la communication avec les modules 
configurés est possible avec la fonction SCXI_ModuleID_Read de 
NI-DAQ ou en utilisant un VI LabVIEW que vous pouvez trouver 
sur ni.com/express en entrant le code d’information rdtscp.
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SCXI  Schnellstart-Anleitung
Signal Conditioning eXtensions for Instrumentation (Signalkonditionie-
rungserweiterungen zur Instrumentierung)

Um diese Anleitung verwenden zu können, muss bereits ein Datenerfas-
sungsgerät (DAQ-Gerät) installiert, konfiguriert und überprüft worden 
sein. Falls das nicht der Fall ist, folgen Sie zunächst den Anweisungen in 
der mitgelieferten DAQ Schnellstart-Anleitung für NI-DAQ 7.0. Für 
PXI-Chassis, PXI-Combo-Chassis, SCXI-1000DC-Chassis, SCXI-Schalt-
module, Multichassis-Systeme oder Module im parallelen Betriebsmodus 
gilt dieses Dokument nicht. Für diesbezügliche Informationen steht Ihnen 
die Modul-, Chassis- oder Kabeladapter-Dokumentation zu Verfügung. 
Bei der Installation eines SCXI-Switches gilt der NI-Switches Getting 
Started Guide.
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Symbole und Darstellungen
In dieser Anleitung werden folgende Symbole und Darstellungen 
verwendet:

» Das Symbol » kennzeichnet die Reihenfolge, in der Menübefehle und 
Dialogfeldoptionen auszuführen sind. So wird zum Beispiel mit der 
Abfolge Datei»Seiteneinstellungen»Optionen angezeigt, dass zunächst 
das Menü Datei zu öffnen ist, hieraus die Option Seiteneinstellungen und 
daraus der Befehl Optionen zu wählen ist.

Dieses Symbol steht für einen Hinweis und macht auf wichtige 
Informationen aufmerksam.

Dieses Symbol kennzeichnet eine Warnung vor möglichen 
Beschädigungen, Datenverlust oder Systemabsturz.

fett In fettgedruckter Schrift sind Elemente dargestellt, die ausgewählt oder 
angeklickt werden müssen, wie beispielsweise Menüelemente oder 
Dialogfeldoptionen. 

gesperrt Im Sperrdruck sind neben Textstellen oder Zeichen, die über die Tastatur 
einzugeben sind, Code-Abschnitte, Programmierbeispiele und 
Syntaxbeispiele dargestellt. Daneben wird diese Darstellungsweise für 
Laufwerke, Pfade, Verzeichnisse, Programme, Unterprogramme, 
Subroutinen, Gerätenamen, Funktionen, Operationen, Eigenschaften, 
Methoden, Variablen, Dateinamen und -erweiterungen sowie für 
Ausschnitte aus Programmcodes verwendet.

kursiv Kursiv gedruckt sind Variablen, Hervorhebungen, Querverweise oder 
Einführungen in wichtige Begriffe. Daneben werden Textstellen, an denen 
ein Wort oder ein korrekter Wert einzusetzen ist, in kursiver Schreibweise 
gekennzeichnet.
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Übersicht Messsysteme
Abbildung 1 stellt einen Überblick über die Messsysteme dar und soll 
aufzeigen, wie reelle physikalische Werte mit Ihrer Messanwendung 
verbunden werden. Komponenten zur Signalkonditionierung arbeiten mit 
Sensoren und Wandlern, mit deren Hilfe Signale gemessen und über die 
Applikationssoftware aufbereitet dargestellt werden.

Abbildung 1.  Messsysteme
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Schritt 1. Auspacken von Modul und Zubehör
Um zu verhindern, dass Ihr Modul durch elektrostatische Entladung 
beschädigt wird, wurde es in einer antistatischen Verpackung ausgeliefert. 
Durch elektrostatische Entladung können Komponenten des Moduls 
beschädigt werden.

Vorsicht! Freiliegende Enden von Anschlusspins nicht mit den Fingern berühren.

Um Schäden durch elektrostatische Entladung zu vermeiden, sollten fol-
gende Vorsichtsmaßnahmen ergriffen werden:

• Erden Sie sich selbst durch Berühren eines geerdeten Objektes oder 
durch die Verwendung eines Erdungskabels. 

• Bringen Sie vor dem Auspacken die Verpackung mit einem blanken 
Metallteil des Chassis in Kontakt.

Überprüfen Sie das Modul auf Beschädigung oder lose Teile nach dem Ent-
fernen der Verpackung. Setzen Sie sich bei Beanstandungen mit der Firma 
National Instruments in Verbindung. Beschädigte Module dürfen nicht in 
das Chassis eingebaut werden.

Wenn Sie das Modul nicht nutzen, lagern Sie es in der Originalverpackung.

Informationen zur Sicherheit und dem richtigen Gebrauch finden Sie auch 
in der Beschreibung des entsprechenden Gerätes.
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Schritt 2. Prüfen der Komponenten
Stellen Sie sicher, dass die Hauptkomponenten vorhanden sind.

Schritt 3. Einrichten des Chassis

Vorsicht! Vor Hardware-Installation ist unbedingt eine Erdung gemäß VDE erforderlich.

1. Chassis ausschalten und Netzstecker ziehen.

2. Setzen Sie die Chassis-Adressschalter auf AUS. In der Abbildung auf 
der nächsten Seite befinden sich sämtliche Schalter in Aus-Stellung.

Hinweis Ältere Chassis arbeiten mit Jumpern im Frontpanel anstelle der Chassis-Adress-
schalter. Ältere Chassis unterscheiden sich auch durch die verwendeten Sicherungen und 
Spannungsversorgung (AC). Weitere Informationen finden Sie in der Beschreibung des 
entsprechenden Chassis.

1 Anschlussblöcke oder TBX -Zubehör (optional)
2 SCXI-Module
3 SCXI-1000 oder SCXI-1001-Chassis
4 Chassis-Stromversorgungskabel

5 Kabelbaugruppe (abgeschirmtes Kabel und 
Kabeladapter)

6 DAQ-Gerät
7 PC

1 2 3 4

C 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 C

V 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 V

SCXI

1140 

SCXI

1140 

®

MAINFRAME 

SCXI

5 6 7
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3. Vergewissern Sie sich, dass die korrekte Spannung verwendet wird 
(100, 120, 220 oder 240 V~).

4. Schließen Sie das Netzkabel an.

Schritt 4. Installation der Module

Vorsicht! Das Chassis muss ausgeschaltet sein. 

1. Stecken Sie alle Module ins Chassis. 

2. Ziehen Sie die Sicherungsschrauben an.

1 Netzschalter
2 Adressschalter

3 Spannungsauswahl
4 Netzkabelanschluss

1

3

2

4
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Schritt 5. Befestigen der Anschlussblöcke
Befestigen Sie die Anschlussblöcke an der Vorderseite der Module. Die 
möglichen Kombinationen von Anschlussblöcken und Modulen finden Sie 
unter ni.com/products. In der TBX-Installationsanleitung befinden sich 
Informationen für den TBX-Anschlussblock, falls Sie einen solchen 
Adapter verwenden.

1 Flügelschrauben 2 Modul

1 Module mit vorinstallierten Anschlussblöcken
2 Befestigen eines Anschlussblocks am SCXI-Modul
3 SCXI-Modul-Frontpanel

®

5
4
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2
1

1

1

2

®

5
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3
2
1
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Schritt 6. Anhängen von Sensoren
Verbinden Sie die Sensoren mit dem Anschlussblock bzw. den Anschlüs-
sen des Zubehörs.

• Informationen zur Signalverbindung finden Sie in der Dokumentation 
des Moduls oder Zubehörs.

• Zu Modulen mit Schalter- oder Jumpereinstellungen finden Sie 
weitere Informationen zur Hardwarekonfiguration im Handbuch 
Getting Started with SCXI.

• Weitere Informationen über Sensoren erhalten Sie:

– auf der Internetseite ni.com/sensors.

– im Handbuch LabVIEW Measurements Manual, das auch auf der 
Internetseite ni.com/manuals verfügbar ist.

• Bei Verwendung einer anderen Applikationssoftware können Sie die 
NI-DAQmx-Hilfe verwenden, die Informationen über allgemeine 
Messungen enthält. Über Start»Programme»National Instruments»
NI-DAQ»NI-DAQmx Help kann auf die Hilfe zugegriffen werden.

Schritt 7. Verbinden der Module mit dem DAQ-Gerät

1. Bei Bedarf Adapter anschließen.

• Falls in Ihrem System mehrere Module vorhanden sind, schließen 
Sie den SCXI-Adapter an die Rückseite des Gerätes an, das in der 
folgenden Liste zuerst aufgeführt ist.

– SCXI-1520, SCXI-1530, SCXI-1531, SCXI-1540, 
SCXI-1581, SCXI-1140

– SCXI-1102, SCXI-1102/B/C, SCXI-1104/C, SCXI-1112, 
SCXI-1125, SCXI-1126, SCXI-1141, SCXI-1142, 
SCXI-1143

– SCXI-1100, SCXI-1120/D, SCXI-1121, SCXI-1122

– SCXI-1124, SCXI-116x

• Falls Sie nur ein Modul einsetzen wollen, verbinden Sie den 
Kabeladapter mit diesem Modul.

Verwenden Sie die mitgelieferten Schrauben, um den Adapter am 
Chassis zu befestigen.

Vorsicht! Den Adapter nicht gewaltsam anbringen, da die Anschlusspins sonst beschädigt 
werden können.
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2. Schließen Sie ein Ende des Kabels an den Adapter oder das Modul an 
und das andere Ende an das DAQ-Gerät. Achten Sie darauf, welches 
SCXI-Modul mit dem DAQ-Gerät verbunden ist, da Sie diese Informa-
tion in einem späteren Schritt benötigen werden.

Schritt 8. Einschalten des PXI-Chassis
Der Chassis-Netzschalter ist in Schritt 3 abgebildet.

Schritt 9. Starten des Measurement & Automation 
Explorer (MAX)

Klicken Sie das Symbol des Measurement & Automation auf dem 
Desktop doppelt an, um den MAX zu öffnen.

Hinweis Anleitungen zur SCXI-Konfiguration von Produkten der RT-Serie finden Sie 
im Hardware Installation Wizard unter ni.com/support/install. Klicken Sie auf 
Hardware Configuration und anschließend auf Real-Time Configuration Wizard.

Schritt 10. Hinzufügen von PXI-Chassis

1. Klicken Sie mit der rechten Maustaste auf Geräte und Schnittstellen 
und wählen Sie Neu.
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2. Wählen Sie ein SCXI-Chassis aus dem Fenster “Hinzufügen” aus.

Wenn Sie mehr als ein NI-DAQ-API zur Steuerung eines SCXI-
Chassis in Ihrer Applikation verwenden, fügen Sie das Chassis jeder 
verwendeten NI-DAQ-API hinzu.

• Bei Verwendung des traditionellen NI-DAQ-Treibers ist das 
Chassis unter traditionelles NI-DAQ-Gerät zu verwenden.

• Bei Verwendung von NI-DAQmx wählen Sie das Chassis unter 
NI-DAQmx Device»NI-DAQmx SCXI Chassis.

Falls ein Gerät sowohl durch den traditionellen NI-DAQ-Treiber als 
auch durch NI-DAQmx unterstützt wird und beide Treiber installiert 
sind, wird das Gerät mit unterschiedlichen Namen in beiden Treiber-
ordnern im Verzeichnis Geräte und Schnittstellen angezeigt.

Hinweis Weitere Informationen über den traditionellen NI-DAQ und die 
NI-DAQmx-Applikations-Programmierschnittstellen (APIs) finden Sie in der Schnell-
start-Anleitung für NI-DAQ 7.0.

3. Zum Fertigstellen klicken Sie auf Beenden. Sie sehen nun ein 
Konfigurationsfenster. Weitere Informationen finden Sie in 
Schritt 11. Konfiguration des Chassis.

Sollte das Gerät nicht automatisch angezeigt werden, drücken Sie <F5>, 
um die Anzeige des MAX zu aktualisieren. Falls das Gerät dann immer 
noch nicht erscheint, können Informationen zur Fehlerbehebung unter 
ni.com/support/install eingeholt werden.

Bei Verwendung des traditionellen NI-DAQ-Treibers gibt es eine weitere 
Möglichkeit, ein SCXI-Chassis hinzuzufügen. Klicken Sie mit der rechten 
Maustaste auf Geräte und Schnittstellen»Traditionelle NI-DAQ-Geräte 
und wählen Sie SCXI-Chassis hinzufügen.

Wenn Sie NI-DAQmx verwenden, klicken Sie mit der rechten Maustaste 
auf Geräte und Schnittstellen»NI-DAQmx Devices und wählen Sie New 
NI-DAQmx Device aus. Danach klicken Sie auf NI-DAQmx SCXI 
Chassis und wählen das entsprechende Chassis aus.

Schritt 11. Konfiguration des Chassis
Mit der NI-DAQ-API kann die Konfiguration zur Steuerung des Chassis 
mit dem traditionellen NI-DAQ- und den NI-DAQmx-Treiber vorgenom-
men werden.
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Traditioneller NI-DAQ
Bei Verwendung des traditionellen NI-DAQ-Treibers müssen Sie, wie 
in den Abbildungen dargestellt, zur Konfiguration des SCXI-Chassis 
folgende Schritte durchführen.

1. Wählen Sie eine ID für das SCXI-Chassis aus. Diese ID kann eine 
beliebige ganze Zahl zwischen 1 und 3200 sein und dient zur Identifi-
zierung des Chassis in der Applikation.

2. Nehmen Sie die Chassis-Adresseinstellungen vor. Die Adresse des 
Chassis kann einen Wert zwischen 0 und 31 haben. Es ist zu beachten, 
dass die Einstellung mit den SCXI-Chassis-Adressschaltern überein-
stimmt. Wo sich diese Schalter befinden, ist in Schritt 3. Einrichten des 
Chassis erläutert. Klicken Sie anschließend auf Weiter.

3. Die automatische SCXI-Modulerkennung kann aktiviert bzw. deakti-
viert werden. Klicken Sie anschließend auf Weiter.

4. Wählen Sie das DAQ-Gerät aus, das für die Kommunikation zwischen 
Chassis und Computer verwendet werden soll. Klicken Sie anschlie-
ßend auf Weiter.

5. Wählen Sie das mit dem Kommunikationsgerät verbundene 
SCXI-Modul aus. Wenn sich im Chassis nur ein einziges Modul 
befindet, wird es automatisch ausgewählt.

21 3
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6. Klicken Sie auf Beenden, um die Einstellungen zu übernehmen.

NI-DAQmx
Bei Verwendung des NI-DAQmx-Treibers müssen, wie in den Abbildun-
gen gezeigt, folgende Schritte zur Konfiguration des Chassis durchgeführt 
werden.

1. Aus dem Feld Chassis Communicator ist das DAQ-Gerät auszuwäh-
len, das mit dem kommunizierenden SCXI-Modul verbunden ist. 
Findet der MAX nur ein DAQ-Gerät, wird dieses Gerät automatisch 
ausgewählt und die Option zur Auswahl ist deaktiviert.

2. Wählen Sie aus dem Pulldown-Menü Communicating SCXI Module 
Slot den Steckplatz aus, in dem sich das mit dem Chassis-Kommuni-
kator verbundene Modul befindet.

3. Nehmen Sie die Chassis-Adresseinstellungen unter Chassis Address 
vor. Vergewissern Sie sich, dass diese mit der Adresseneinstellung auf 
Ihrem SCXI-Chassis übereinstimmen.

4. Die automatische SCXI-Modulerkennung kann aktiviert bzw. deakti-
viert werden. Wenn die automatische Modulerkennung nicht aktiviert 
ist, wird das Pulldown-Menü “Communicating SCXI Module Slot” 
deaktiviert.

Vorsicht! Durch die automatische Modulerkennung können die Module in einen unbe-
kannten oder unerwünschten Status versetzt werden. Trennen Sie die Verbindung zu den 
Geräten, denen die automatische Modulerkennung Probleme bereiten könnte.

6

54
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5. Klicken Sie auf Save.

6. Das SCXI-Chassis-Konfigurationsfenster wird geöffnet. Die Register-
karte Modules ist bereits per Voreinstellung ausgewählt. Wenn die 
automatische Modulerkennung nicht aktiviert wurde, muss ein 
SCXI-Modul aus dem Listenfeld Modules ausgewählt werden. Verge-
wissern Sie sich, dass sich das Modul im richtigen Steckplatz befindet.

7. Standardmäßig wird im Feld Device Name immer ein Name ange-
zeigt. Um den Namen zu verändern, klicken Sie in das Feld und geben 
einen eindeutigen alphanumerischen Namen für das SCXI-Modul ein.

8. Soll Zubehör verwendet werden, ist dieses über Accessory 
auszuwählen.

9. Details ermöglicht die Auswahl weiterer Konfigurationsoptionen. 
Weitere Informationen finden Sie in Schritt 12. Konfiguration des 
SCXI-Moduls.

10. Wenn an Chassis-Einstellungen Änderungen vorgenommen werden 
sollen, ist dazu die Registerkarte Chassis anzuklicken. Für die meisten 
Anwendungen werden allerdings keine Änderungen notwendig sein.

11. Über einen Klick auf OK werden die Änderungen für das Chassis 
gespeichert.

1

2

3

4

5
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Hinweis Vor dem Speichern der Chassis-Konfiguration muss die Eingabe der Modulinfor-
mationen abgeschlossen sein. Eine Meldung im oberen Bereich des Fensters “SCXI 
Chassis Configuration” macht auf den aktuellen Konfigurationsstatus aufmerksam. Wird 
in diesem Fenster eine Fehlermeldung angezeigt, ist kein Speichern möglich. Wird eine 
Warnung angezeigt, ist zwar eine Speicherung der Konfiguration möglich, es wird jedoch 
empfohlen, vorher die Ursache der Warnung zu finden und das Problem zu beheben.

Schritt 12. Konfiguration des SCXI-Moduls
Die zur Konfiguration des SCXI-Moduls erforderlichen Schritte richten 
sich danach, ob zur Programmierung des Moduls die NI-DAQ-API für den 
traditionellen NI-DAQ- oder den NI-DAQmx-Treiber verwendet wird.

Traditioneller NI-DAQ
Bei Verwendung des traditionellen NI-DAQ-Treibers müssen zur Konfigu-
ration der SCXI-Module folgende Schritte durchgeführt werden.

1. Wählen Sie unter Geräte und Schnittstellen»Traditionelle 
NI-DAQ-Geräte ein Chassis aus.

2. Klicken Sie mit der rechten Maustaste auf einen Modulsteckplatz und 
wählen Sie Eigenschaften.

610 7 8 9

11
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3. Die Registerkarte Allgemein ist bereits per Voreinstellung ausgewählt. 
Über die Option Verbinden mit kann das DAQ-Gerät ausgewählt wer-
den, das mit dem Modul verbunden werden soll. Markieren Sie das 
Kontrollkästchen, wenn das Chassis vom DAQ-Gerät gesteuert wird.

4. Bei einigen Modulen kann zwischen Multiplex- und Parallelmodus 
gewählt werden. Stellen Sie einen Betriebsmodus ein.

5. Einige Module enthalten Filter und/oder Verstärkungen für jeden 
Kanal, die über die Software ausgewählt werden können. Die verfüg-
baren Einstellungen sind von Modul zu Modul unterschiedlich. Wenn 
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Sie ein solches Gerät verwenden, klicken Sie auf die Registerkarte 
Kanal, und nehmen Sie die entsprechenden Einstellungen vor.

6. Klicken Sie auf die Registerkarte Zubehör. Wählen Sie aus dem 
Zubehör-Listenfeld ein kompatibles Gerät aus.

7. Klicken Sie auf OK, um die Einstellungen zu übernehmen.

NI-DAQmx
Beim Einsatz des NI-DAQmx-Treibers gehen Sie zur Konfiguration 
der Module folgendermaßen vor (dieser Schritt entfällt, wenn im 
SCXI-System ein einzelnes MIO-Gerät im Multiplexmodus verwendet 
wird):

1. Wählen Sie unter Geräte und Schnittstellen»NI-DAQmx Devices 
das entsprechende Chassis aus.

2. Klicken Sie mit der rechten Maustaste auf das Modul und wählen Sie 
Properties.
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Hinweis Auf die Moduleigenschaften kann auch zugegriffen werden, indem die Register-
karte Modules des SCXI-Chassis-Konfigurationsfensters gewählt und danach auf Details 
geklickt wird.

3. Zu einigen SCXI-Modulen können bestimmte Einstellungen auch über 
Jumper vorgenommen werden. Zur Konfiguration eines solchen 
Moduls geben Sie auf der Registerkarte Jumpers die an der Hardware 
vorgenommenen Einstellungen ein.
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4. Klicken Sie auf die Registerkarte Accessory.

5. Um die während der Chassis-Konfiguration vorgenommenen 
Einstellungen zur Zusatz-Hardware zu ändern, verwenden Sie das 
Drop-Down-Listenfeld Accessory.

6. Zubehöreinstellungen sind unter Configure vorzunehmen. Die Option 
“Einstellungen” ist jedoch nicht zu allen Zusatzgeräten verfügbar. 
Weitere Informationen finden Sie in der entsprechenden Beschreibung 
des Zusatzgerätes.

7. Bei der Verwendung von AI-Modulen ist die Registerkarte Cabling 
anzuklicken.

Hinweis Im standardmäßigen Multiplexmodus ist keine Anpassung der Optionen 
auf der Registerkarte Cabling erforderlich, sondern nur im Parallelmodus, bei 
Multichassis-Konfigurationen oder einer anderen Spezialkonfiguration.

8. Klicken Sie im Drop-Down-Listenfeld Which device connects to this 
module? das DAQ-Gerät an, das mit dem SCXI-Modul verbunden ist. 
Meistens sind das ausgewählte Gerät und der Digital-umsetzer ein und 
dasselbe Gerät.

9. Wählen Sie ein DAQ-Gerät aus dem Drop-Down-Listenfeld Module 
Digitizer. Dabei muss es sich nicht um das gleiche Gerät wie unter 
Which device connects to this module? handeln.

10. Im parallelen Betriebsmodus ist die Option Parallel Mode 
anzuklicken.
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11. Wenn sich das Modul in einem Chassis befindet, das mit einem 
anderen kaskadiert ist, wählen Sie aus dem Drop-Down-Listenfeld 
Multichassis Daisy-Chain Index eine Indexnummer aus. Das Listen-
feld wird nur dann angezeigt, wenn mindestens zwei Chassis 
hinzugefügt und gespeichert worden sind.

12. Klicken Sie auf OK.

Weitere Informationen über softwarekonfigurierbare Eigenschaften von 
Modulen finden Sie in der Hilfe zum Measurement & Automation Explorer 
für den traditionellen NI-DAQ-Treiber oder in der Measurement & 
Automation Explorer Help for NI-DAQmx. Um auf diese Hilfe im MAX 
zuzugreifen, wählen Sie Hilfe»Hilfe-Themen und dann entweder 
traditioneller NI-DAQ-Treiber oder NI-DAQmx.

Schritt 13. Überprüfung des Chassis
Stellen Sie sicher, dass das Chassis vom MAX erkannt wird.

1. Klicken Sie unter Geräte und Schnittstellen das zu überprüfende 
Chassis in der NI-DAQ-API mit der rechten Maustaste an.

2. Wählen Sie Test. Bei erfolglosem Test mit dem NI-DAQmx-Treiber 
erhalten Sie eine Meldung mit einer Erklärung des Fehlers.
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Schritt 14. Konfiguration der Kanäle und Tasks
Ein physikalischer Kanal ist ein Anschluss bzw. Pin, an dem ein analoges 
oder digitales Signal gemessen oder erzeugt wird. Ein virtueller Kanal ist 
eine Sammlung von Einstellungen zu einem physikalischen Kanal (z. B. 
Bezeichnung, Anschlussverbindung, Art der Messung oder Signalerzeu-
gung, Skalierung). Beim traditionellen NI-DAQ-Treiber und in früheren 
Versionen kann über die Konfiguration virtueller Kanäle festgestellt 
werden, welche Kanäle für verschiedene Messungen verwendet werden. 
Bei NI-DAQmx sind virtuelle Kanäle Bestandteil einer jeden Messung.

Beim traditionellen NI-DAQ-Treiber werden virtuelle Kanäle mit Hilfe des 
MAX konfiguriert. In NI-DAQmx können virtuelle Kanäle mit Hilfe des 
DAQ-Assistenten konfiguriert werden, der sich vom MAX oder von der 
Applikationssoftware aus öffnen lässt. Ein Konfigurieren virtueller Kanäle 
ist aber auch mit der NI-DAQmx-API Ihres Anwendungsprogramms 
möglich.

Ein Task ist ein wichtiger neuer Bestandteil von NI-DAQmx, der mehrere 
virtuelle Kanäle umfasst sowie Einstellungen zum Timing, zur Triggerung 
und zu weiteren Eigenschaften ermöglicht. Ein Task ist eine Messung oder 
Signalerzeugung, die durchgeführt werden soll. Sämtliche Konfigurations-
informationen eines Tasks können nach dem Einrichten gespeichert 
werden und der Task kann danach als Applikation verwendet werden.

In NI-DAQmx können virtuelle Kanäle als Teil eines Tasks konfiguriert 
oder von diesem getrennt werden. Virtuelle Kanäle, die innerhalb eines 
Tasks erstellt wurden, werden als lokale Kanäle bezeichnet. Dagegen 
werden virtuelle Kanäle, die außerhalb eines Tasks erstellt wurden, als 
globale Kanäle bezeichnet. Globale Kanäle können Sie entweder den 
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MAX oder Ihre Applikations-Software verwenden. Globale Kanäle 
können in jeder beliebigen Applikation verwendet oder verschiedenen 
Tasks hinzugefügt werden. Bei der Modifizierung eines globalen Kanals 
betrifft die Änderung aller darauf bezogener Tasks. In den meisten Fällen 
ist es jedoch einfacher, lokale Kanäle zu verwenden.

Konfiguration eines Tasks in NI-DAQmx
Bei der Verwendung von NI-DAQmx müssen Tasks mit Hilfe des 
DAQ-Assistenten konfiguriert werden. Zum Erstellen von Tasks und 
Kanälen mit dem DAQ-Assistenten muss das Anwendungssoftwarepaket 
von National Instruments der Version 7.0 installiert sein.

• Klicken Sie im MAX mit der rechten Maustaste auf Datenumgebung 
und wählen Sie Neu. Klicken Sie auf die Schaltfläche NI-DAQmx 
Task und anschließend auf Weiter.

• Der DAQ-Assistent lässt sich auch direkt aus der Anwendungssoft-
ware heraus öffnen.

– In LabVIEW gibt es zum Öffnen des DAQ-Assistenten folgende 
Möglichkeiten:

• Fügen Sie das Express-VI “DAQ-Assistent” der 
Express-Palette entsprechend der Beschreibung unter Erste 
Schritte mit LabVIEW ein.

• Alternativ kann auch das Bedienelement “DAQmx-
Taskname” verwendet werden. Klicken Sie mit der 
rechten Maustaste auf das Bedienelement und wählen Sie 
Neuer Task (DAQ-Assistent). Das Hilfe-Tutorium Taking 
an NI-DAQmx Measurement in LabVIEW enthält 
Schritt-für-Schritt-Anweisungen dazu, wie mit dem 
Bedienelement DAQmx-Task-Name ein Task erstellt und 
Code erzeugt werden kann. Um es zu öffnen, wählen Sie 
Hilfe»Taking an NI-DAQmx Measurement.

– In LabWindows™/CVI™ ist Tools»Create/Edit DAQmx Tasks 
auszuwählen.

– Nach dem Öffnen von Visual Studio .NET in Measurement Studio 
wählen Sie Project»Add New Item, um das Dialogfeld “Add 
New Item” anzuzeigen. Danach ist Measurement Studio»
Assistants aus dem Kategorie-Fenster auszuwählen. Wählen Sie 
anschließend DAQmx Task Class aus dem Vorlagen-Fenster aus.

Der DAQ-Assistent wird geöffnet.
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Um einen neuen Task zu erstellen, ist den Anweisungen des Dialogs zu 
folgen.

1. Danach ist ein I/O-Typ (z. B. analoger Eingang) zu wählen.

2. Anschließend ist die Art der auszuführenden Messung bzw. Signaler-
zeugung zu bestimmen.

3. Falls zutreffend, ist der zu verwendende Sensor auszuwählen.

4. Als nächstes ist zu entscheiden, welche Kanäle dem Task hinzugefügt 
werden sollen. Es können dem Task globale Kanäle hinzugefügt 
werden oder physikalische Kanäle gewählt werden, aus denen dann 
lokale Kanäle innerhalb des Tasks erzeugt werden.

5. Bei Bedarf können nun messungsspezifische Einstellungen sowie 
Timing und Triggering vorgenommen werden.

6. Der Task ist nun zu speichern.

• Sofern der DAQ-Assistent von LabVIEW oder von 
LabWindows/CVI aus geöffnet wurde, klicken Sie auf OK.

• Wurde der DAQ-Assistent von Measurement Studio aus geöffnet, 
ist File»Save anzuklicken.

Nun kann der Task in einer Applikation verwendet werden. Weitere Infor-
mationen über die Verwendung von Tasks oder die Erzeugung von Code 
befinden sich in der DAQ Assistant Help bzw. in der Dokumentation zur 
Applikations-Software.
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Konfiguration globaler Kanäle in NI-DAQmx
Bei der Verwendung von NI-DAQmx müssen globale Kanäle mit Hilfe des 
DAQ-Assistenten konfiguriert werden.

• Klicken Sie im MAX mit der rechten Maustaste auf Datenumgebung 
und wählen Sie Neu. Wählen Sie im Fenster Neu erstellen die Schalt-
fläche NI-DAQmx Global Channel aus und klicken Sie auf Weiter.

• Der DAQ-Assistent lässt sich auch direkt von LabVIEW 7.0, 
LabWindows/CVI 7.0 oder von Measurement-Studio 7.0 aus öffnen. 

– In LabVIEW ist dazu das Bedienelement DAQmx-Globaler Kanal 
zu verwenden. Klicken Sie mit der rechten Maustaste auf das 
Bedienelement und wählen Sie Neuer Kanal (DAQ-Assistent).

– In LabWindows/CVI oder Measurement-Studio muss zunächst, 
wie zuvor beschrieben, ein Task erstellt werden. Um dem Task 
globale Kanäle hinzuzufügen, ist im DAQ-Assistenten Add 
Existing DAQmx Global Channels anzuklicken.

Der DAQ-Assistent wird geöffnet. Um einen neuen globalen Kanal zu 
erstellen, ist den Online-Anweisungen zu folgen.

1. Es ist ein I/O-Typ (z. B. analoger Eingang) zu wählen.

2. Anschließend ist die Art der auszuführenden Messung bzw. Signaler-
zeugung zu bestimmen.

3. Falls zutreffend, ist der zu verwendende Sensor auszuwählen.

4. Bestimmen Sie dann den zu verwendenden physikalischen Kanal.

5. Dem folgen die messungsspezifischen Einstellungen.

6. Task speichern.

• Sofern der DAQ-Assistent von LabVIEW oder von 
LabWindows/CVI aus geöffnet wurde, klicken Sie auf OK.

• Wurde der DAQ-Assistent von Measurement Studio aus geöffnet, 
ist File»Save anzuklicken.

Der globale Kanal kann nun in jeder beliebigen Applikation verwendet 
oder einem Task hinzugefügt werden. Weitere Informationen über die Ver-
wendung eines Kanals oder die Erzeugung von Code finden Sie in der Hilfe 
zum DAQ-Assistenten  bzw. in der Applikations-Software-Dokumentation.

Konfiguration virtueller Kanäle für den traditionellen NI-DAQ-Treiber
Bei Verwendung des traditionellen NI-DAQ-Treibers sind virtuelle Kanäle 
im MAX zu konfigurieren.

1. Klicken Sie im MAX mit der rechten Maustaste auf Datenumgebung 
und wählen Sie Neu.
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2. Wählen Sie Virtueller Kanal für traditionellen NI-DAQ im Fenster 
“Hinzufügen” und klicken Sie anschließend auf Beenden. Daraufhin 
öffnet sich der Assistent “Neuen Kanal erstellen”.

3. Folgen Sie den Anweisungen des Assistenten, um den neuen Kanal zu 
erstellen. Zusätzliche Informationen über die Konfiguration verschie-
dene Kanaltypen erhalten Sie in der Hilfe zum Measurement & 
Automation Explorer für den traditionellen NI-DAQ-Treiber.

Erste Schritte bei Erstellung einer Applikation

Beispiele
Jede API enthält eine Vielzahl von Programmierbeispielen, die das Erstel-
len einer Applikation vereinfachen. Die Beispielcodes können bearbeitet 
und für eine Applikation verwendet werden. Sie können die Beispiele zur 
Erstellung einer neuen Applikation verwenden oder einer bestehenden 
Applikation hinzufügen.

Zum Auffinden von LabVIEW- und LabWindows/CVI-Beispielen öffnen 
Sie die NI-Suchmaschine für Beispiele:

• In LabVIEW wählen Sie Hilfe»Beispiele suchen.

• In LabWindows/CVI klicken Sie auf Help»NI Example Finder.



© National Instruments Corporation 85 SCXI Schnellstart-Anleitung

In folgenden Verzeichnissen sind Beispiele für Measurement Studio, 
Visual Basic und ANSI C verfügbar:

• NI-DAQmx-Beispiele für von Measurement Studio unterstützte 
Programmiersprachen befinden sich in folgenden Verzeichnissen:

– MeasurementStudio\VCNET\Examples\DAQmx 

– MeasurementStudio\DotNET\Examples\DAQmx

• Beispiele für den traditionellen NI-DAQ-Treiber zur Verwendung in 
Visual Basic finden Sie unter:

– NI-DAQ\Examples\Visual Basic with Measurement-
Studio (enthält einen Link zu den Beispielen zur Verwendung 
der ActiveX-Controls von Measurement Studio).

– NI-DAQ\Examples\VBasic (enthält von Measurement Studio 
unabhängige Beispiele).

• Im Verzeichnis NI-DAQ\Examples\DAQmx ANSI C Dev erhalten Sie 
NI-DAQmx-Beispiele für ANSI C.

• Unter NI-DAQ\Examples\VisualC befinden sich Beispiele für den 
traditionellen NI-DAQ-Treiber für ANSI C.

Zusätzliche Beispiele sind unter ni.com/zone verfügbar.

Informationen über Messapplikationen und Messgeräte
Jedes Anwendungssoftwarepaket mit Treiber enthält Informationen zum 
Erstellen von Applikationen für Messungen sowie zur Steuerung von 
Messgeräten. Die im Folgenden genannten Dokument-Referenzen haben 
Gültigkeit unter der Voraussetzung, dass NI-DAQ 7.0 und, wo notwendig, 
die NI-Anwendungssoftware der Version 7.0 installiert sind.

LabVIEW
Neuanwender sollten sich zunächst mit dem Handbuch Erste Schritte mit 
LabVIEW befassen, um mit LabVIEW vertraut zu werden. Wählen Sie 
dazu Start»Programme»National Instruments»LabVIEW»Im 
LabVIEW-Bücherregal suchen.

Im LabVIEW Measurements Manual finden Sie API-Übersichten zum tra-
ditionellen NI-DAQ- und zum NI-DAQmx-Treiber sowie Beschreibungen 
zu Messvorgängen. Klicken Sie dazu Start»Programme»National
Instruments»LabVIEW»LabVIEW-Bibliothek durchsuchen an.

Das Hilfe-Tutorium Taking an NI-DAQmx Measurement in LabVIEW 
enthält Schritt-für-Schritt-Anweisungen dazu, wie ein Messvorgang in 
LabVIEW einzurichten ist und beschreibt neue NI-DAQmx-Funktionen 
sowie spezielle Konzepte, wie beispielsweise den DAQ-Assistenten und 
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Tasks. Nach Auswahl von Help»Taking an NI-DAQmx Measurement in 
LabVIEW wird das Tutorium geöffnet.

In der LabVIEW Traditional NI-DAQ VI Reference Help und der LabVIEW 
NI-DAQmx VI Reference Help sind LabVIEW-VIs und deren Eigenschaf-
ten beschrieben. Wählen Sie dazu in LabVIEW Hilfe und dann die 
LabVIEW-VI Referenz-Hilfe für die verwendete NI-DAQ-API aus.

LabWindows/CVI
In der Datenerfassungsbibliothek der LabWindows/CVI Help sind 
API-Übersichten, Konzepte zu Messvorgängen und Informationen zu 
Funktionen zum traditionellen NI-DAQ- und dem NI-DAQmx-Treiber 
enthalten. Um sie zu öffnen, wählen Sie in LabWindows/CVI 
Help»Contents.

Measurement Studio
Die Hilfe zu NI Measurement Studio enthält eine Übersicht über 
NI-DAQmx-APIs, Messvorgänge, Konzepte und Informationen zu 
Funktionen. Diese Hilfedatei ist Bestandteil der Visual-Studio-.NET-
Dokumentation. Um sie zu öffnen, klicken Sie in Visual Studio .NET die 
Option Help»Contents an.

Die Measurement Studio Reference enthält die API-Übersicht des traditio-
nellen NI-DAQ-Treibers, Konzepte zu Messvorgängen und Informationen 
zu Funktionen. Um sie zu öffnen, klicken Sie in Visual Studio .NET 
Measurement Studio»Measurement Studio Reference an.

ANSI C ohne NI-Anwendungssoftware
Übersichten über APIs finden Sie im Traditional NI-DAQ User Manual 
und der NI-DAQmx Help. Die NI-DAQmx Help enthält zusätzlich allge-
meine Informationen zu Messvorgängen. In der Traditional NI-DAQ 
C Reference Help und der NI-DAQmx C Reference Help finden Sie eine 
Übersicht über die Funktionen und Attribute von C. Wählen Sie 
Start»Programme»National Instruments»NI-DAQ und den Titel des 
Dokuments der verwendeten NI-DAQ-API aus.

.NET-Sprachen ohne NI-Anwendungssoftware
Die NI Measurement Studio Help enthält eine Übersicht über 
NI-DAQmx-APIs, Messvorgänge, Konzepte und Informationen zu 
Funktionen. Diese Hilfedatei ist Bestandteil der Visual-Studio-.NET-
Dokumentation. Um sie zu öffnen, klicken Sie in Visual Studio .NET die 
Option Help»Contents an.
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Hinweis Bei Verwendung einer .NET-Sprache ohne Visual Studio .NET kann es vorkom-
men, dass die NI Measurement Studio Help nicht eingesehen werden kann.

Gerätedokumentation
Zu NI-DAQ 7.0 gibt es eine Online-Dokumentation für unterstützte DAQ-, 
SCXI- und Switchgeräte, die über den Gerätedokumente-Browser einseh-
bar ist. Dabei handelt es sich um Hilfedateien zu Geräteanschlüssen, 
Eigenschaften und Operationen sowie um Gerätedokumente im PDF-
Format. Diese Suchmaschine steht Ihnen jederzeit zur Verfügung, da sie 
sich auf der CD mit der Gerätedokumentation befindet. Nach der Installa-
tion des Gerätedokumente-Browsers kann über Start»Programme»
National Instruments»NI-DAQ»Browse Device Documentation auf die 
Dokumente zugegriffen werden.

Konfiguration von SCXI- und Switch-Multi-Chassis
Im SCXI-1346 Shielded Multi-Chassis Cable Installation Guide finden Sie 
Setup-Anweisungen zur Erstellung von SCXI- und Switch-Multi-Chassis-
Applikationen.

Switch
In der NI Switches Help sind technischer Support und Programmierunter-
stützung für das Schaltmodul und den NI-SWITCH-Instrumententreiber 
verfügbar.

Der NI-SWITCH Instrument Driver Quick Reference Guide enthält eine 
API- sowie eine Funktion/VI-Übersicht.

Kurse
Für weiterführende Anleitung bei der Entwicklung von Applikationen mit 
NI-Produkten bietet die Firma National Instruments Trainingskurse an. 
Anmeldeinformationen und Kursinhalte können der Internetseite 
ni.com/training entnommen werden.

Technische Unterstützung
Weitere Unterstützung finden Sie unter ni.com/support oder 
ni.com/zone.
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Fehlersuche
Das Chassis ist eingeschaltet und meine Module sind für den 
Multiplexmodus konfiguriert. Dennoch kann ich an keinem Kanal die 
erwarteten Messwerte erfassen. Wodurch wird dieses Problem 
verursacht?

SCXI-Chassis sind mit Sicherungen versehen, die sich auf der Rückwand-
platine im Chassis befinden. Dabei handelt es sich um 1,5 A-Sicherungen 
beim SCXI-1000-Chassis und 4 A-Sicherung beim SCXI-1001-Chassis. 
Diese Sicherungen könnten durchgebrannt sein.

Beim SCXI-1000-Chassis sind diese Sicherungen nur nach Entfernen des 
Lüfters zugänglich. Beim SCXI-1001 befinden sie sich auf der Rückseite 
hinter dem rechten Lüfter in der Nähe des Stromversorgungsmoduls.

Führen Sie zum Überprüfen oder Austausch von Sicherungen folgende 
Schritte durch.

1. Chassis ausschalten und Netzkabel entfeiner.

2. Die vier Halteschrauben des Lüfters mit Filter entfernen. Vor Entfer-
nen der letzten Schraube Lüfter festhalten, da beim Herausfallen des 
Lüfters die Leitungsdrähte beschädigt werden könnten.

3. Die Sicherungen sind mit einem + bzw. einem – gekennzeichnet. Zur 
Überprüfung einer Sicherung ist ein Ohmmeter zu verwenden. Sollte 
die Ablesemarke des Messgerätes nicht auf 0 Ω  stehen, ist die Siche-
rung zu ersetzen.

4. Sicherung mit Hilfe einer Spitzzange vorsichtig entfernen.

5. Drähte der neuen Sicherung umbiegen, so dass die Länge der 
Komponente 12,7 mm ist—dies entspricht der Länge des Sicherungs-
sockels—danach gebogene Enden auf 6,4 mm absetzen.

6. Sicherung mit Hilfe einer Spitzzange vorsichtig in den Sicherungssok-
kel einsetzen.

7. Bei Bedarf diesen Vorgang für die andere Sicherung wiederholen.

8. Lüfter mit Filter bei nach unten zeigender Beschriftung wieder in die 
vorgesehene Öffnung einsetzen. Schrauben einsetzen und anziehen.

Das Chassis hat einwandfrei funktioniert, bis ich versehentlich ein 
Modul während des Betriebes ausgetauscht habe. Nun lässt sich das 
Chassis nicht wieder einschalten. Was ist zu tun?

SCXI-Module sind nicht während des Netzbetriebes austauschbar, daher 
ist wahrscheinlich beim Austausch eine Sicherung durchgebrannt. Wenn 
der Austausch einer Sicherung keine Abhilfe schaffen sollte, könnten der 
digitale Bus-Schaltkreis oder das SCXI-Modul beschädigt worden sein. 
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In diesem Fall ist über ni.com/support technische Unterstützung 
heranzuziehen.

Wenn ich einen Test durchführen will, wird das Chassis im MAX nicht 
erkannt. Was ist zu tun?

Überprüfen Sie:

• ob das Chassis eingeschaltet ist.

• ob das Chassis ordnungsgemäß mit einem DAQ-Gerät verbunden ist. 
Wenn mehrere DAQ-Geräte installiert sind, ist zu kontrollieren, ob das 
für den Chassis Communicator gewählte Gerät auch tatsächlich mit 
dem Chassis verbunden ist.

• ob irgend ein Pin der Rückwandplatine bei der Modulinstallation 
beschädigt worden ist.

• die korrekte Platzierung und Konfiguration der Module. Wenn die 
automatische Modulerkennung nicht aktiviert wurde, könnte es sein, 
dass im Chassis installierte Module nicht in der Software konfiguriert 
sind oder die in der Software konfigurierten Module nicht mit den 
installierten Modulen des Chassis übereinstimmen.

Ist es möglich, den Netzbetriebszustand des Chassis programmatisch 
festzustellen?

Nur indirekt. Sie können die Kommunikation mit den konfigurierten 
Modulen testen, indem Sie die Funktion SCXI_ModuleID_Read des 
NI-DAQ verwenden oder mit einem speziellen LabVIEW-VI. Dieses VI ist 
durch Eingabe des Infocodes rdtscp unter ni.com/express erhältlich.
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SCXI  クイックスタートガイド
計測用信号調節拡張システム

この文書では、データ集録（DAQ）デバイスの取り付け、構成、テスト

が既に完了していることを前提としています。完了していない場合は、

DAQ デバイスに付属の『DAQ Quick Start Guide for NI-DAQ 7.0』の

説明に従ってそれらを完了させてから続行してください。この文書では、

PXI シャーシ、PXI コンビネーションシャーシ、SCXI-1000DC シャーシ、

SCXI スイッチモジュール、マルチシャーシシステム、およびモジュール

のパラレルモード操作については扱いません。これらの情報については、

モジュール、シャーシ、またはケーブルアダプタのマニュアルを参照して

ください。SCXI スイッチモジュールを使用する場合は、『NI Switches 
Getting Started Guide』を参照してください。
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表記規則

本書では以下の表記規則を使用します。

→ →記号に沿って、入れ子のメニュー項目やダイアログボックスをたどって

いくと、最終的に必要な操作を実行することができます。ファイル→ペー

ジ設定→オプションという順になっている場合、まずファイルメニューを

プルダウンし、次にページ設定項目を選択して、最後のダイアログボック

スからオプションを選択します。

このアイコンは、注意すべき重要な情報があることを示しています。

このアイコンは、人体への損傷、データの損失、システムのクラッシュな

どを防止するための注意事項があることを示しています。

太字 太字のテキストは、メニュー項目やダイアログボックスなど、ソフトウェ

アでユーザが選択（クリック）する必要のある項目を表します。また、フ

ロントパネル上のパラメータ名、制御器やボタン、ダイアログボックスま

たはその一部、メニュー名、パレット名も表します。

下線 下線つきのテキストは、重要な事項を示します。

斜体 このフォントスタイルは変数を示します。または、ユーザが入力する必要

がある語または値のプレースホルダを示します。

monospace このフォントのテキストは、キーボードから入力する必要のあるテキスト

や文字、 コードの一部、プログラムサンプル、構文例を表します。また、

ディスクドライブ名、パス名、ディレクトリ名、プログラム名、サブプロ

グラム名、サブルーチン名、デバイス名、関数名、演算名、変数名、ファ

イル名と拡張子、引用するコードにも使います。ただし、日本語の文字の

入力や表示は、前後の文と区別するため、「」で囲んでいる場合もありま

す。
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計測システムの概要

図 1 はこの計測システムの概要で、実際の物理現象がどのような流れで

計測アプリケーションに取り入れられるかを示しています。信号調節シス

テムでは、センサーとトランスデューサを使用して信号を計測し、アプリ

ケーションソフトウェアで解析して、その解析結果が出力されます。

図 1 計測システムの概要

+
V
–

+
HV
–

+
mV
–

+

–

8

7

6

ON

STANDBY

®

MAINFRAME 

SCXI

SC-2345



SCXI クイックスタートガイド 94 ni.com/jp

手順 1. モジュールとアクセサリの梱包を解く

ご使用のモジュールは、静電気による損傷（ESD、静電破壊）を防ぐた

め、静電防止の梱包で出荷されています。これは、静電破壊によってモ

ジュールの部品が損傷を受けるおそれがあるためです。

注意 露出しているコネクタピンには絶対に触れないでください。

モジュールを扱うときにこのような損傷を回避するには、以下の予防措置

を講じてください。

• 接地ストラップを使用したり、接地された物体に触れたりして、身体

を接地する。

• 静電防止の梱包をシャーシの金属部分に接触させてから、モジュール

を梱包箱から取り出す。

モジュールを箱から取り出し、部品がゆるんでいないかどうか、また、損

傷箇所がないかどうかを調べます。モジュールが損傷している場合は、ナ

ショナルインスツルメンツまでご連絡ください。損傷しているモジュール

はシャーシに取り付けないでください。

モジュールを使用しないときは、静電防止の梱包に保管してください。

保安と準拠については、デバイスのマニュアルを参照してください。
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手順 2. コンポーネントを確認する

必要なコンポーネントが梱包されているかどうかを確認します。

1 ターミナルブロックまたは TBX アクセサリ（オプション）

2 SCXI モジュール

3 SCXI-1000/SCXI-1001 シャーシ

4 シャーシの電源コード

5 ケーブルアセンブリ（被膜ケーブルおよびケーブルア
ダプタ）

6 DAQ デバイス
7 PC
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手順 3. シャーシをセットアップする

注意 適切な静電破壊防止対策により身体が接地されていることを必ず確認してから、

ハードウェアを取り付けてください。

1. シャーシの電源を切り、コードを抜いてください。

2. シャーシのアドレススイッチをオフに設定します。下の図では、ス

イッチはすべてオフの位置にあります。

メモ 旧タイプのシャーシには、正面パネルの内側にジャンパを使用し、シャーシア

ドレススイッチを使用しないものがあります。ヒューズと AC 電源の選択に関

しても異なります。詳細については、それぞれのシャーシ関連文書を参照して

ください。

3. 適切な電源設定（100/120/220/240 VAC）を確認します。

4. 電源コードを接続します。

1 シャーシの電源スイッチ

2 シャーシのアドレススイッチ
3 シャーシの電源設定

4 電源コードのコネクタ
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手順 4. モジュールを取り付ける

注意 シャーシの電源がオフであることを確認してください。 

1. すべてのモジュールをシャーシに挿入します。

2. モジュールのつまみネジを締めます。

1 つまみネジ 2 モジュール
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手順 5. ターミナルブロックを取り付ける

モジュールの正面にターミナルブロックを取り付けます。正しいターミナ

ルブロックおよびモジュールの組み合わせについての情報は、ni.com/

jp/productsを参照してください。TBX アダプタを使用している場合は、

ターミナルブロックの TBX のインストレーションガイドを参照してくだ

さい。

手順 6. センサーを取り付ける

センサーをターミナルブロックまたはアクセサリの端子に配線します。 

• 信号接続については、モジュールまたはアクセサリのマニュアルを参

照してください。 

• SCXI システムのいずれかのモジュールにスイッチまたはジャンパ設

定がある場合は、より詳しいハードウェア設定について『SCXI 入門』

を参照してください。

• センサーについては、以下の文書を参照してください。

– センサーを使用する場合は、ni.com/sensorsを参照してくだ

さい。

– LabVIEW を使用する場合は、LabVIEW に付属している

『LabVIEW Measurements Manual』を参照してください。こ

のマニュアルは ni.com/manuals（英語）からも参照できます。 
– 他のアプリケーションソフトウェアを使用する場合、一般的な計

測については『NI-DAQmx Help』を参照してください。ヘルプ

ファイルは、スタート→プログラム→ National Instruments →

NI-DAQ → NI-DAQmx Help から表示することができます。

1 ターミナルブロックがモジュールに取り付けられた状態

2 ターミナルブロックの SCXI モジュールへの取り付け

3 SCXI モジュールの正面パネル
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手順 7. モジュールを DAQ デバイスに接続する

1. 必要に応じてケーブルアダプタを取り付けます。

• システムに複数のモジュールがある場合は、どのモジュールが下

のリストで一番目にあるかを調べます。そして、ケーブルアダプ

タをその SCXI モジュールの後部コネクタに取り付けます。 

– SCXI-1520、SCXI-1530、SCXI-1531、SCXI-1540、
SCXI-1581、SCXI-1140

– SCXI-1102、SCXI-1102/B/C、SCXI-1104/C、SCXI-1112、
SCXI-1125、SCXI-1126、SCXI-1141、SCXI-1142、SCXI-1143

– SCXI-1100、SCXI-1120/D、SCXI-1121、SCXI-1122

– SCXI-1124、SCXI-116x

• モジュールが 1 つしかない場合は、ケーブルアダプタをそのモ

ジュールに取り付けてください。

付属のネジを使用して、アダプタをシャーシに固定します。

注意 抵抗を感じた場合、アダプタを無理に押し込まないでください。アダプタを無

理に押し込もうとすると、ピンが曲がるおそれがあります。

2. ケーブルの一端をアダプタまたはモジュールに、もう一端を DAQ デ

バイスに接続します。どの SCXI モジュールが DAQ デバイスに接続

されているかに留意してください。この情報は後で必要となります。

手順 8. SCXI シャーシに電源を投入する

シャーシの電源スイッチは、手順 3 に示すとおりです。

手順 9. Measurement & Automation Explorer
（MAX）を起動する

デスクトップにある Measurement & Automation アイコンをダブルク

リックして MAX を起動します。

メモ RT シリーズの製品に付属の SCXI の構成についての説明は、ni.com/support/

installから Hardware Installation Wizard を参照してください。

Hardware Configuration を選択して Real-Time Configuration Wizard をク

リックします。
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手順 10. SCXI シャーシを追加する

1. デバイスとインタフェースを右クリックして、新規作成を選択します。

2. 新規作成のウィンドウから SCXI シャーシを選択します。

複数の NI-DAQ API を使用してアプリケーションの SCXI シャーシを

制御する場合は、使用している NI-DAQ API のそれぞれに シャーシ

を追加してください。

• 従来型 NI-DAQ を使用している場合は、従来型 NI-DAQ デバイ

スの下にあるシャーシを選択します。

• NI-DAQmx を使用する場合は、NI-DAQmx デバイス→

NI-DAQmx SCXI Chassis を選択し、その下にあるシャーシを

選択します。

従来型 NI-DAQ および NI-DAQmx の両方でデバイスがサポートされ

ていて、両方ともインストールされている場合は、同じデバイスは

「デバイスとインタフェース」の従来型 NI-DAQ デバイスフォルダお

よび NI-DAQmx フォルダの下にそれぞれ表示されます。

メモ 従来型 NI-DAQ および NI-DAQmx アプリケーションプログラミングインタ

フェース（API）についての詳細は、『DAQ Quick Start Guide for 
NI-DAQ 7.0』を参照してください。

3. 終了したら、終了をクリックします。構成ウィンドウが表示されま

す。詳細については、「手順 11. シャーシを設定する」を参照してく

ださい。

デバイスが自動的に表示されない場合には、<F5> を押して MAX の表示

を更新します。デバイスがまだ認識されないときは、ni.com/

support/installのトラブルシューティングを参照してください。

従来型 NI-DAQ を使用する場合は、別の方法で SCXI シャーシを追加する

こともできます。デバイスとインタフェースを右クリックして従来型

NI-DAQ デバイスを選択したら、Add SCXI Chassis を選択します。
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NI-DAQmx を使用する場合は、別の方法で SCXI シャーシを追加するこ

ともできます。デバイスとインタフェースの下にある NI-DAQmx デバイ

スを右クリックして、Create New NI-DAQmx Device を選択します。

NI-DAQmx SCXI Chassis を選択してシャーシを選びます。

手順 11. シャーシを設定する

構成の手順は、シャーシの制御に使用する NI-DAQ API（従来型 NI-DAQ
または NI-DAQmx）によって異なります。

従来型 NI-DAQ
従来型 NI-DAQ を使用する場合、SCXI シャーシを構成するには、図にも

示されている以下の手順に従ってください。

1. SCXI シャーシの ID を選択します。ID には 1 ～ 3,200 の任意の整数

を使用することができます。この ID を使用してアプリケーションの

シャーシを識別してください。

2. シャーシのアドレス設定を入力します。シャーシのアドレスには、

0 ～ 31 の任意の値を使用することができます。設定が SCXI シャー

シのシャーシアドレスのスイッチと一致していることを確認してくだ

さい。「手順 3. シャーシをセットアップする」にシャーシのスイッチ

の位置についての情報が載っています。次へをクリックします。

3. SCXI モジュールを自動検出するかどうかを選択します。次へをク

リックします。
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4. DAQ デバイスを選択します。このデバイスは、シャーシとコン

ピュータの間の通信パスのように動作します。次へをクリックします。

5. ケーブルで通信デバイスに接続した SCXI モジュールを選択します。

シャーシにモジュールが 1 つしかない場合、デフォルトで NI-DAQ
はそのモジュールを選択します。

6. 完了をクリックして設定を承諾します。
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NI-DAQmx
NI-DAQmx を使用する場合は、以下の手順に従って図のようにシャーシ

を構成してください。

1. Chassis Communicator から、SCXI 通信モジュールにケーブルで

接続した DAQ デバイスを選択します。MAX が DAQ デバイスを 1
つだけ検出している場合は、デフォルトによりそのデバイスが選択さ

れ、このメニューは操作不可となります。

2. Communicating SCXI Module Slot から、Chassis 
Communicator に接続されているモジュールスロットを選択します。

3. Chassis Address にシャーシアドレスの設定を入力します。設定が

SCXI シャーシのアドレス設定と一致することを確認してください。

4. SCXI モジュールを自動検出するかどうかを選択します。モジュール

を自動検出しない場合は、Communicating SCXI Module Slot 設定

が無効になります。

注意 モジュールの自動検出が原因で、モジュールが不明な状態や望ましくない状態

になるおそれがあります。自動検出において問題が発生する原因となる可能性

のある、すべてデバイスをシステムから外してください。

5. Save をクリックします。
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6. SCXI Chassis Configuration ウィンドウが開きます。デフォルトに

より、Modules タブが選択されます。モジュールを自動検出しな

かった場合は、Modules リストボックスから SCXI モジュールを選

択します。モジュールを正しいスロットに配置してください。

7. MAX は Device Name フィールドにデフォルトの名前を表示しま

す。デバイス名を変更するには、そのフィールドをクリックして

SCXI モジュールの固有の ID を英数字で入力します。

8. アクセサリを使用する場合は、Accessory からそれを選択します。

9. 構成オプションの詳細は、Details をクリックしてください。詳細に

ついては、「手順 12. SCXI モジュールを設定する」を参照してくださ

い。

10. シャーシの設定を変更する必要がある場合は、Chassis をクリック

します。通常、シャーシの設定を変更する必要はありません。

11. OK をクリックして、このシャーシ設定を承諾、保存します。

メモ モジュール情報を入力しないと、シャーシの構成を保存することはできません。

SCXI Chassis Configuration ウィンドウ上部のメッセージは、構成の状態を示

します。メッセージにエラー表示された場合、保存することはできません。

メッセージボックスに警告が表示された場合も構成を保存することはできます

が、警告が出された問題を解消してから構成を保存することを推奨します。
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手順 12. SCXI モジュールを設定する

構成の手順は、モジュールをプログラムするために使用する

NI-DAQ API、つまり、従来型 NI-DAQ か NI-DAQmx かによって異なり

ます。

従来型 NI-DAQ
従来型 NI-DAQ を使用する場合、以下の手順に従って、SCXI モジュール

を構成してください。

1. デバイスとインタフェースの下にある従来型 NI-DAQ デバイスを選

択して、シャーシを選択します。

2. モジュールのスロットを右クリックしてプロパティを選びます。
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3. デフォルトにより、一般設定タブが選択されます。モジュールに接続

する DAQ デバイスを接続先から選択します。DAQ デバイスが

シャーシを制御する場合は、チェックボックスにチェックマークを付

けます。

4. 操作モード（マルチプレクスまたはパラレル）設定が必要なモジュー

ルもあります。モードを操作モードから選択します。

5. 各チャネルに、ソフトウェア選択可能フィルタ、ゲイン設定の両方あ

るいは片方の特徴を備えたモジュールもあります。使用可能な設定は

モジュールによって異なります。該当する場合、チャネルタブをク

リックして、表示されたフィールドから設定を選択します。

6. アクセサリタブをクリックします。アクセサリリストボックスから対

応するデバイスを選択します。

7. OK をクリックして設定を承諾します。
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NI-DAQmx
NI-DAQmx を使用する場合、以下の手順に従ってモジュールを構成して

ください。マルチプレクスモードで SCXI システムに単一の MIO デバイ

スを使用している場合には、この手順を省略することができます。

1. デバイスとインタフェースの下にある NI-DAQmx デバイスを選択し

て、シャーシを選択します。

2. そのモジュールを右クリックして Properties を選択します。

メモ SCXI Chassis Configuration ウィンドウの Modules タブを選択して Details
をクリックする方法でも、モジュールのプロパティにアクセスすることができ

ます。
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3. ジャンパ選択が可能な設定の SCXI モジュールもあります。そのよう

なモジュールを構成する場合は、Jumpers タブをクリックしてハー

ドウェアで選択した設定を入力します。

4. Accessory タブをクリックします。

5. シャーシ構成中に選択したアクセサリを変更するには、Accessory
ドロップダウンリストボックスからモジュールのアクセサリを選択し

ます。

6. Configure をクリックして設定を承諾します。すべてのアクセサリ

に設定があるとは限りません。詳細については、アクセサリのマニュ

アルを参照してください。
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7. AI モジュールを使用している場合は、Cabling タブをクリックして

ください。

メモ 標準のマルチプレクスモードの操作を使用している場合には、Cabling タブの

情報を調整する必要はありません。パラレルモードの操作、マルチシャーシ構

成、または別の特別な構成を使用している場合には、Cabling タブのオプショ

ンを調整してください。

8. Which device connects to this module? ドロップダウンリスト

ボックスから、SCXI モジュールに接続した DAQ デバイスを選択し

ます。通常、この時点で選択したデバイスは、Module Digitizer と
同じです。

9. Module Digitizer ドロップダウンリストボックスから DAQ デバイ

スを選択します。そのデバイスは Which device connects to this 
module? リストボックスから選択したデバイスとは異なる可能性が

あります。

10. パラレルモードで操作している場合は、Parallel Mode をクリック

します。

11. デイジーチェーン接続のシャーシにモジュールが取り付けられている

場合は、Multichassis Daisy-Chain Index ドロップダウンリスト

ボックスからインデックス番号を選択します。2 つ以上のシャーシが

追加、保存されたときのみ、リストボックスが表示されます。

12. OK をクリックします。

ソフトウェア構成可能なプロパティについては、『従来型 NI-DAQ 用

Measurement & Automation Explorer のヘルプ』または

『Measurement & Automation Explorer の NI-DAQmx のヘルプ』を参

照してください。MAX にあるこのヘルプを開くには、ヘルプ→ヘルプト
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ピック→従来型 NI-DAQ またはヘルプ→ヘルプトピック→ NI-DAQmx を

選択してください。

手順 13. シャーシをテストする

MAX がシャーシを認識したかどうか確認します。

1. デバイスとインタフェースの下でテストする NI-DAQ API にある

シャーシ名を右クリックします。

2. Test を選択します。NI-DAQmx を使用してテストに失敗した場合

は、その失敗について説明するメッセージが表示されます。

手順 14. チャネルの構成とタスクの設定

物理チャネルとは、アナログ / デジタル信号を計測または生成できる端子

またはピンのことです。これに対して、仮想チャネルとは、名前、物理

チャネル、入力端子接続、計測または生成のタイプ、およびスケール情報

を含む設定のコレクションです。従来型 NI-DAQ とそれ以前のバージョ

ンでは、仮想チャネルの構成は、どのチャネルがどの計測に使用されてい

るかを登録するオプション機能です。NI-DAQmx では、仮想チャネルは

すべての計測に不可欠です。

従来型 NI-DAQ では、MAX を使用して仮想チャネルを構成しますが、

NI-DAQmx では、DAQ アシスタントで仮想チャネルを構成することが

できます。この DAQ アシスタントは、MAX やアプリケーションソフト

ウェアから開くことができます。また、アプリケーションプログラムで、

NI-DAQmx API を使用して仮想チャネルを構成することもできます。

タスクとは、NI-DAQmx で使用される新しい重要な概念で、タイミング、

トリガ、その他のプロパティ情報とともに、単一または複数の仮想チャネ
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ルを集めたものです。概念としては、タスクは実行する計測または生成を

意味しています。タスク内の構成情報はすべて設定または保存して、アプ

リケーションで使用することができます。

NI-DAQmx では、仮想チャネルをタスクの一部として、またはタスクか

ら切り離して構成できます。タスク内に作成した仮想チャネルは、ローカ

ルチャネルです。タスク外に定義した仮想チャネルは、グローバルチャネ

ルです。グローバルチャネルは、MAX 内あるいはアプリケーションソフ

トウェア内に作成して、MAX に保存することができます。また、どのア

プリケーションでも使用することができる上、さまざまなタスクにそれら

を追加することもできます。グローバルチャネルを変更した場合は、その

変更がそのグローバルチャネルに関連するすべてのタスクに影響を及ぼし

ます。通常、ローカルチャネルを使用するほうが簡単です。

NI-DAQmx でタスクを設定する
NI-DAQmx を使用する場合は、DAQ アシスタントでタスクを構成しま

す。DAQ アシスタントでタスクおよびチャネルを作成するには、NI アプ

リケーションソフトウェアパッケージのバージョン 7．0 を必ず使用して

ください。

• MAX でデータ設定を右クリックして、新規作成を選択します。新規

作成ウィンドウで NI-DAQmx Task を選択して、次へをクリックし

ます。

• また、NI アプリケーションソフトウェアの中から直接 DAQ アシス

タントを開くこともできます。

– LabVIEW では、さまざまな方法で DAQ アシスタントを開くこ

とができます。

• 『LabVIEW 入門』の説明に従って、DAQ アシスタント 
Express VI を Express 入力パレットから取り出します。

• DAQmx タスク名制御器を使用して DAQ アシスタントを開

くこともできます。制御器を右クリックして、新規タスクを

選択します。『Taking an NI-DAQmx Measurement in 
LabVIEW』には、DAQmx タスク名制御器でタスクを作成

する方法およびタスクのためのコードを生成する方法につい

て、段階的な説明が記載してあります。LabVIEW では、

ヘルプ→ Taking an NI-DAQmx Measurement を選択し

てチュートリアルを開きます。

– LabWindows™/CVI™ では、Tools → Create/Edit DAQmx 
Tasks を選択します。

– Measurement Studio では、Visual Studio .NET を開いて、

Project → Add New Item を選択して Add New Item ダイアロ

グボックスを開きます。Categories ぺーンで、Measurement 
Studio → Assistants を選択します。Templates ぺーンでは、

DAQmx Task Class を選択します。

DAQ アシスタントが開きます。
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新しいタスクを作成するには、オンラインの説明に従ってください。

1. アナログ入力などの I/O タイプを選択します。

2. 実行する計測または生成を選択します。

3. 使用するセンサーを選択します（該当する場合）。

4. チャネルを選択して、タスクを追加します。グローバルチャネルをタ

スクに追加するか、タスク内のローカルチャネルを作成する物理チャ

ネルを選択します。

5. 必要に応じて、その計測に適した設定、タイミング、およびトリガを

設定します。 

6. タスクを保存します。

• LabVIEW または LabWindows/CVI から DAQ アシスタントを

開いて、OK をクリックします。

• Measurement Studio から DAQ アシスタントを開いた場合は、

File → Save を選択します。

これで、アプリケーションでタスクを使用することができます。タスクや

コード生成についての詳細は、『DAQ Assistant Help』を参照するか、ア

プリケーションソフトウェアのマニュアルを参照してください。
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NI-DAQmx のグローバルチャネルを構成する
NI-DAQmx を使用する場合は、DAQ アシスタントでグローバルチャネ

ルを構成します。

• MAX でデータ設定を右クリックして、新規作成を選択します。新規

作成ウィンドウで、NI-DAQmx Global Channel を選択して、次へ

をクリックします。

• DAQ アシスタントは、LabVIEW 7.0、LabWindows/CVI 7.0、また

は Measurement Studio 7.0 内から直接開くこともできます。

– LabVIEW では、DAQmx Global Channel 制御器を使用して

DAQ アシスタントを開いてください。制御器を右クリックし

て、新規チャネル（DAQ アシスタント）を選択します。

– LabWindows/CVI または Measurement Studio では、前述の

ように最初にタスクを必ず作成してください。DAQ アシスタン

トでは、Add Existing DAQmx Global Channels をクリック

して、タスクにグローバルチャネルを追加します。

DAQ アシスタントが開きます。新しいグローバルチャネルを作成するに

は、オンラインの説明に従ってください。

1. アナログ入力などの I/O タイプを選択します。

2. 実行する計測または生成を選択します。

3. 使用するセンサーを選択します（該当する場合）。

4. 使用する物理チャネルを選択します。

5. その計測に適した設定を構成します。

6. タスクを保存します。

• LabVIEW または LabWindows/CVI から DAQ アシスタントを

開いて、OK をクリックします。

• Measurement Studio から DAQ アシスタントを開いた場合は、

File → Save を選択します。

これで、アプリケーションでのグローバルチャネルの使用およびグローバ

ルチャネルのタスクへの追加ができるようになりました。チャネルやコー

ド生成についての詳細は、『DAQ アシスタント ヘルプ』を参照するか、

アプリケーションソフトウェアのマニュアルを参照してください。
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従来型 NI-DAQ の仮想チャネルを構成する
従来型 NI-DAQ を使用するときは、MAX で仮想チャネルを構成します。

1. MAX でデータ設定を右クリックして、新規作成を選択します。

2. 新規作成ウィンドウで仮想チャネルを選択し、終了をクリックしま

す。新規作成ウィザードが開きます。

3. 新規作成チャネルウィザードの説明に従って、新しいチャネルを作成

します。さまざまなチャネルタイプの構成についての詳細は、従来型

『NI-DAQ Measurement & Automation Explorer ヘルプ』を参照

してください。

アプリケーション開発を開始する

サンプル
各 API にはプログラミングサンプルのコレクションが含まれており、

アプリケーション開発を手がける際に役立ちます。サンプルのコードは、

変更したり、アプリケーションに保存したりすることができます。サンプ

ルを使用すると、新しいアプリケーションを開発したり、サンプルのコー

ドを既存のアプリケーションに加えたりすることができます。

お望みの LabVIEW および LabWindows/CVI のサンプルを見つけるに

は、以下の要領で NI サンプルファインダを開いてください。

• LabVIEW では、ヘルプ→サンプルの検索を選択します。

• LabWindows/CVI では、Help → NI Example Finder を選択します。
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Measurement Studio、Visual Basic および ANSI C のサンプルは、以

下のディレクトリにあります。

• Measurement Studio でサポートされる言語の NI-DAQmx のサン

プルは、以下のディレクトリにあります。

– MeasurementStudio¥VCNET¥Examples¥DAQmx

– MeasurementStudio¥DotNET¥Examples¥DAQmx

• Visual Basic 用の従来型 NI-DAQ サンプルは、以下のディレクトリ

にあります。

– NI-DAQ¥Examples¥Visual Basic with Measurement Studio
ディレクトリには、Measurement Studio の ActiveX コント

ロールを使用した場合の Visual Basic のサンプルがあります。

– NI-DAQ¥Examples¥VBasic ディレクトリには、

Measurement Studio を使用しない Visual Basic のサンプルが

あります。

• ANSI C 用 NI-DAQmx サンプルは、NI-DAQ¥Examples¥DAQmx ANSI 
C Dev ディレクトリにあります。

• ANSI C 用従来型 NI-DAQ サンプルは、NI-DAQ¥Examples¥VisualC 

ディレクトリにあります。

その他のサンプルについては、ni.com/zoneを参照してください。

計測アプリケーションとデバイスの情報
各アプリケーションソフトウェアのパッケージおよびドライバには、計測

および計測デバイス制御用アプリケーションの構築についての情報が含ま

れています。以下のリファレンス文書では、NI-DAQ 7.0、NI アプリケー

ションソフトウェアのバージョン 7.0（該当する場合）を使用しているこ

とを想定して記載されています。

LabVIEW
はじめてご使用になる場合には、『LabVIEW 入門』をお読みになり、

LabVIEW の基本操作を習得してください。スタート→プログラム→

National Instruments → LabVIEW → LabVIEW ドキュメントライブラ

リを表示を選択します。

『LabVIEW Measurements Manual』には従来型 NI-DAQ および

NI-DAQmx の API の概要が載っており、計測の概念が説明されていま

す。スタート→プログラム→ National Instruments → LabVIEW →

LabVIEW ドキュメントライブラリを表示を選択します。

『Taking an NI-DAQmx Measurement in LabVIEW』ヘルプのチュート

リアルでは、LabVIEW での計測をセットアップする方法が段階ごとに説

明されています。また、新しい重要な特徴や概念の説明も記載してありま

す。ヘルプ→ Taking an NI-DAQmx Measurement を選択してチュー

トリアルを開きます。
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『LabVIEW 従来型 NI-DAQ VI リファレンスヘルプ』および『LabVIEW 
NI-DAQmx VI Reference Help』には、LabVIEW VI およびプロパティ

についての説明があります。LabVIEW のヘルプからオンラインヘルプを

開き、VI と関数リファレンスでお使いの API についてご参照ください。

LabWindows/CVI
『LabWindows/CVI Help』のデータ集録ライブラリには、従来型

NI-DAQ および NI-DAQmx の API の概要、計測の概念、関数のリファレ

ンスが含まれます。LabWindows/CVI では、Help → Contents を選択

します。

Measurement Studio
『NI Measurement Studio Help 』には、NI-DAQmx API の概念、計測

タスクおよび概念、関数リファレンスについて記載されています。このヘ

ルプファイルは Visual Studio .NET のマニュアルに統合されています。

Visual Studio .NET では、Help → Contents を選択します。

『Measurement Studio Reference』には、従来型 NI-DAQ API の概要

や、計測の概念、関数リファレンスが記載されています。Visual Studio 
.NET では、Measurement Studio → Measurement Studio Reference
を選択します。

ANSI C - NI アプリケーションソフトウェア不使用
『Traditional NI-DAQ User Manual』および『NI-DAQmx Help』には

API の概念についてが記載されています。『NI-DAQmx Help』にも、計

測の概念についての一般情報が記載されています。『Traditional NI-DAQ 
C Reference Help』および『NI-DAQmx C Reference Help』には、C
関数と属性についての説明が記載されています。スタート→プログラム→

National Instruments → NI-DAQ を選択して、使用している

NI-DAQ API のマニュアルのタイトルを選択します。

.NET 言語 - NI アプリケーションソフトウェア不使用
『NI Measurement Studio Help 』には、NI-DAQmx API の概念、計測

タスクおよび概念、関数リファレンスについて記載されています。このヘ

ルプファイルは Visual Studio .NET のマニュアルに統合されています。

Visual Studio .NET では、Help → Contents を選択します。

メモ Visual Studio .NET を使わずに .NET 言語を使用する場合は、

『NI Measurement Studio Help』を表示できない可能性があります。
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デバイスの文書
NI-DAQ 7.0 には Device Document Browser があり、サポートのある

DAQ、SCXI やスイッチデバイスのオンライン文書（デバイスのピンの並

び順、特性、操作を説明したヘルプファイル、デバイスのドキュメント

（PDF）など）が含まれます。CD を挿入して Device Document 
Browser を使用すると、各デバイスのドキュメントを検索、表示、印刷

することができます。Device Document Browser をインストール後、

デバイスの文書はスタート→プログラム→ National Instruments →

NI-DAQ → Browse Device Documentation から表示できます。

SCXI およびスイッチのマルチシャーシ構成

『SCXI-1346 Shielded Multi-Chassis Cable Installation Guide』には、

SCXI および Switch のマルチシャーシのアプリケーション開発のための

セットアップの詳細が記載されています。

スイッチ

『NI Switches Help』 には、スイッチモジュールおよび NI-SWITCH 計測器

ドライバ用の技術プログラムサポートがあります。

『NI-SWITCH Instrument Driver Quick Reference Guide』 には、API の
概要および関数 /VI の概念の説明が記載されています。

カスタマートレーニング
ナショナルインスツルメンツでは、NI 製品を使用してアプリケーション

開発を行うためのトレーニングコースを用意しています。トレーニング

コースへのご登録、またはそのコース概要については、ni.com/jp/

trainingをご覧ください。

技術サポート
その他のサポートについては、ni.com/support/jaまたは ni.com/

zoneを参照してください。

トラブルシューティング

シャーシの電源はオンで、モジュールはマルチプレクスモードに構成され

ていますが、どのチャネルでも良いデータが集録できません。何が原因で

しょうか ?

SCXI のシャーシにはバックプレーンフューズが装備されていて、

SCXI-1000 シャーシでは 1.5 A、SCXI-1001 シャーシでは 4 A に設定され

ています。このため、フューズの片方または両方が切断される可能性があ

ります。
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SCXI-1000 では、バックプレーンフューズはファンの後方にあります。

SCXI-1001 では、バックプレーンフューズは、シャーシを後ろから見て

右手のファン後方、電源入力モジュールの付近にあります。

フューズのチェックまたは取り替えには、以下の手順に従ってください。

1. シャーシの電源をオフにして、電源コードを外します。

2. ファンとフィルタをシャーシ後部に固定している 4 つのネジを外し

ます。最後のネジを外したら、ファンのワイヤに損傷を与えないよう

に注意してそれを手で保持します。

3. バックプレーンに銅 + 記号が付いているフューズはアナログ電源

（正）用、銅 - 記号が付いているフューズはアナログ電源用です。

フューズが飛んだかどうかをチェックするには、導線をオームメータ

に接続します。読み取り値が 0 Ωなら、フューズを交換してください。

4. 先の細くとがったペンチを使用して、注意してフューズを取り出します。

5. 新しいフューズを用意します。部品の長さ（フューズのソケット間の

寸法）が 12.7 mm (0.5 in.) になるようにフューズの導線を曲げて、

その導線の曲げた部分から先端までの長さが 6.4 mm (0.25 in.) にな

るように切ります。

6. 先の細くとがったペンチを使用して、フューズをソケット穴へ挿入し

ます。

7. 必要に応じて、他のフューズも同じように処理します。

8. ファンのラベルがある方を下にして、ファンとフィルタをファン穴に

合わせます。4 つのネジをまた取り付け、組み立てが固定しているか

どうかを確認します。

シャーシの電源をオンにしたままモジュールをうっかり外してしまいまし

た。そのままモジュールを元どおり取り付けましたが、シャーシがよく動

作しません。結局、シャーシに電源が入らなくなってしまいました。どう

したらよいでしょうか ?

SCXI モジュールはホットスワップ非対応のため、フューズが飛んでし

まった可能性があります。フューズを取り替えても問題が解消しない場合

は、デジタルバス回路または SCXI モジュールが損傷を受けた可能性があ

ります。ni.com/jp/supportから、ナショナルインスツルメンツの技術

サポートにお問い合わせください。

MAX は、テスト中はシャーシを認識しないのですか ? どうしたらよいで

しょうか ?

以下の項目を確認してください。

• シャーシに電源が入っていることを確認します。

• シャーシが DAQ デバイスに正しく接続されていることを確認しま

す。複数の DAQ デバイスが PC に取り付けられている場合には、

Chassis Communicator として選択されたデバイスが実際にシャー

シに接続されていることを確認します。
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• モジュールの取り付けの際にバックプレーンのピンが曲げられなかっ

たかどうかを確認します。

• モジュールの取り付け方および構成が正しいことを確認します。モ

ジュールが自動検出されなかった場合、シャーシに取り付けられたモ

ジュールはソフトウェアで構成されない可能性があります。また、ソ

フトウェアで構成されたモジュールが、シャーシに取り付けたモ

ジュールと一致していない可能性があります。

シャーシに電源が入っているかどうかをプログラムで検出できますか ?

できないこともありません。NI-DAQ の SCXI_ModuleID_Readを通じ

て、または ni.com/expressで情報コード、rdtscpを入力すると入手

できる LabVIEW VI を使用して、構成されたモジュールと通信できるか

どうかを判断することができます。
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